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Safety Instruction  
 

 

Before using the product … 

 

For your safety and effective operation, please read the safety instructions thoroughly before using the product. 

 

► Safety Instructions should always be observed in order to prevent accident or risk with the safe and 

proper use the product. 

 

► Instructions are divided into “Warning” and “Caution”, and the meaning of the terms is as follows. 

 

This symbol indicates the possibility of serious injury or death if some applicable 

instruction is violated  

 

This symbol indicates the possibility of severe or slight injury, and property 

damages if some applicable instruction is violated 

 

Moreover, even classified events under its caution category may develop into serious accidents relying on 

situations. Therefore we strongly advise users to observe all precautions properly just like warnings. 

 

► The marks displayed on the product and in the user’s manual have the 

following meanings. 

Be careful! Danger may be expected. 

Be careful! Electric shock may occur. 

 

► The user’s manual even after read shall be kept available and accessible to 

 any user of the product. 

Warning 

Caution 
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Safety Instructions for design process 
 
 
 
 
 
 
 
 
 
 
 

 Please install a protection circuit on the exterior of PLC so that the whole system may 

operate safely regardless of failures from external power or PLC. Any abnormal output or 

operation from PLC may cause serious problems to safety in whole system.  

- Install protection units on the exterior of PLC like an interlock circuit that deals with opposite 

operations such as emergency stop, protection circuit, and forward/reverse rotation or install an 

interlock circuit that deals with high/low limit under its position controls. 

- If any system error (watch-dog timer error, module installation error, etc.) is detected during 

CPU operation in PLC, all output signals are designed to be turned off and stopped for safety. 

However, there are cases when output signals remain active due to device failures in Relay and 

TR which can’t be detected. Thus, you are recommended to install an addition circuit to monitor 

the output status for those critical outputs which may cause significant problems.  

 Never overload more than rated current of output module nor allow to have a short circuit. 

Over current for a long period time may cause a fire . 

 Never let the external power of the output circuit to be on earlier than PLC power, which may 

cause accidents from abnormal output or operation. 

 Please install interlock circuits in the sequence program for safe operations in the system 

when exchange data with PLC or modify operation modes using a computer or other 

external equipments Read specific instructions thoroughly when conducting control operations 

with PLC.  

Warning 
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Safety Instructions for design process 
 
 
 
 
 
 
 
 

 
Safety Instructions on installation process 

 I/O signal or communication line shall be wired at least 100mm away from a high-voltage 

cable or power line. Fail to follow this 

Caution 

 Use PLC only in the environment specified in PLC manual or general standard of data 

sheet. If not, electric shock, fire, abnormal operation of the product may be caused. 

 Before install or remove the module, be sure PLC power is off. If not, electric shock or damage 

on the product may be caused. 

 Be sure that every module is securely attached after adding a module or an extension 

connector. If the product is installed loosely or incorrectly, abnormal operation, error or dropping 

may be caused. In addition, contact failures under poor cable installation will be causing 

malfunctions as well. 

 Be sure that screws get tighten securely under vibrating environments. Fail to do so will put 

the product under direct vibrations which will cause electric shock, fire and abnormal operation. 

 Do not come in contact with conducting parts in each module, which may cause electric 

shock, malfunctions or abnormal operation. 

Caution 
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Safety Instructions for wiring process 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Prior to wiring works, make sure that every power is turned off. If not, electric shock or 

damage on the product may be caused. 

 After wiring process is done, make sure that terminal covers are installed properly before 

its use. Fail to install the cover may cause electric shocks. 

Warning 

 Check rated voltages and terminal arrangements in each product prior to its wiring 

process. Applying incorrect voltages other than rated voltages and misarrangement among 

terminals may cause fire or malfunctions. 

 Secure terminal screws tightly applying with specified torque. If the screws get loose, short 

circuit, fire or abnormal operation may be caused. Securing screws too tightly will cause 

damages to the module or malfunctions, short circuit, and dropping. 

 Be sure to earth to the ground using Class 3 wires for FG terminals which is exclusively 

used for PLC. If the terminals not grounded correctly, abnormal operation or electric shock 

may be caused. 

 Don’t let any foreign materials such as wiring waste inside the module while wiring, 

which may cause fire, damage on the product or abnormal operation. 

 Make sure that pressed terminals get tighten following the specified torque. External 

connector type shall be pressed or soldered using proper equipments.  

Caution 
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Safety Instructions for test-operation and maintenance 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 

 
 
 
 

 Don’t touch the terminal when powered. Electric shock or abnormal operation may occur. 

 Prior to cleaning or tightening the terminal screws, let all the external power off including 

PLC power. If not, electric shock or abnormal operation may occur. 

 Don’t let the battery recharged, disassembled, heated, short or soldered. Heat, explosion 

or ignition may cause injuries or fire. 

Warning 

 Do not make modifications or disassemble each module. Fire, electric shock or abnormal 

operation may occur. 

  Prior to installing or disassembling the module, let all the external power off including 

PLC power. If not, electric shock or abnormal operation may occur. 

 Keep any wireless equipment such as walkie-talkie or cell phones at least 30cm away 

from PLC. If not, abnormal operation may be caused. 

 When making a modification on programs or using run to modify functions under PLC 

operations, read and comprehend all contents in the manual fully. Mismanagement will 

cause damages to products and accidents. 

 Avoid any physical impact to the battery and prevent it from dropping as well. Damages 

to battery may cause leakage from its fluid. When battery was dropped or exposed under strong 

impact, never reuse the battery again. Moreover skilled workers are needed when exchanging 

batteries.  

Caution 
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Safety Instructions for waste disposal 
 

 Product or battery waste shall be processed as industrial waste. The waste may discharge 

toxic materials or explode itself. 

Caution 
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About User’s Manual 
 

Congratulations on purchasing PLC of LS Industrial System Co.,Ltd. 

Before use, make sure to carefully read and understand the User’s Manual about the functions, performances, installation 

and programming of the product you purchased in order for correct use and importantly, let the end user and 

maintenance administrator to be provided with the User’s Manual.  

 

The User’s Manual describes the product. If necessary, you may refer to the following description and order accordingly. 

In addition, you may connect our website(http://eng.lsis.biz/) and download the information as a PDF file.  

 

Relevant User’s Manuals 

Title Description 

XG5000 User’s Manual 
(for XGK, XGB) 

XG5000 software user manual describing online function 
such as programming, print, monitoring, debugging by 
using XGK, XGB CPU 

XG5000 User’s Manual 
(for XGI, XGR) 

XG5000 software user manual describing online function 
such as programming, print, monitoring, debugging by 
using XGI, XGR CPU 

XGK/XGB Instructions & Programming 
User’s Manual 

User’s manual for programming to explain how to use 
instructions that are used PLC system with XGK, XGB 
CPU. 

XGI/XGR/XEC Instructions & 
Programming User’s Manual 

User’s manual for programming to explain how to use 
instructions that are used PLC system with XGI, 
XGR,XEC CPU. 

XGK CPU User’s Manual 
(XGK-
CPUA/CPUE/CPUH/CPUS/CPUU) 

XGK-CPUA/CPUE/CPUH/CPUS/CPUU user manual 
describing about XGK CPU module, power module, base, 
IO module, specification of extension cable and system 
configuration, EMC standard 

XGI CPU User’s Manual 
(XGI-CPUU/CPUH/CPUS) 

XGI-CPUU/CPUH/CPUS user manual describing about 
XGI CPU module, power module, base, IO module, 
specification of extension cable and system configuration, 
EMC standard 

XGR redundant series User’s 
Manual 

XGR- CPUH/F, CPUH/T user manual describing about 
XGR CPU module, power module, extension drive, base, 
IO module, specification of extension cable and system 
configuration, EMC standard 
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Chapter 1 Overview 

 

This manual describes the function and operation method of XG-PM. 

XG-PM is the software that controls positioning modules corresponding to CPU of XGT PLC series and carries out the 

functions below. 

 

 Setting Parameter, Data of Positioning Module 

 Simulating by Positioning Data 

 Reading/Writing data on Positioning Module and comparing data with module 

 Monitoring in Positioning Control status 

 Test operating of Positioning Control 

 

These are the positioning module that XG-PM can be applied to 
Positioning module types Models 

Open Collector Ouput APM positioning module XGF-PO1A, XGF-PO2A, XGF-PO3A  

XPM positioning module XGF-PO1H, XGF-PO2H, XGF-PO3H, XGF-PO4H 
Line Drive Output APM positioning module XGF-PD1A, XGF-PD2A, XGF-PD3A  

XPM positoning module XGF-PD1H, XGF-PD2H, XGF-PD3H, XGF-PD4H  
Network type EtherCAT positioning module XGF-PN8A 

Standard type EtherCAT positioning 
module 

XGF-PN8B 
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1.1 Characteristics 
 

   (1) Application of intuitive icon design 
Intuitive icon design is applied for user to operate more easily. 

 

   (2) Three-dimensional Structure to check data Easily and Quickly. 
   Users can check external I/O signal and error history easily and quickly even while data monitoring. Especially, 

users can check error information and solutions on monitoring screen and can be given much help from it. In addition, 

the state of external I/O signal is displayed in various colors for user to check conveniently.  

 

(3) Multi-Communication 
   XG-PM and XG5000are possible to connect at the same time witout extra work for connection. 

 

(4) Editing and Monitoring Data of Several modules at a time 

   XG-PM can edit data of several positioning module connected to XGT PLC and monitor several modules at a time. 

When users install several modules, the modules will be installed easily and quickly. 

 

 (5) Simulator Function 
   XG-PM has simulator for positioning module so simulation is possible to execute before real operating. User can 

check the movement of positioning module through the simulator and prevent some unexpected errors. 

 

 (6) Compatible with Former APM Software Package 
   XG-PM can read files written in former APM software package and convert it into the project file for XG-PM. 

 

(7) Servo-Tuning Function 
  You can connect to the servo and execute the servo-tuning function without other softwares. 

  (There is a limit to the servo tuning function, according to the servo) 

 

 (8) Various Monitor Function 
   XG-PM provides various forms of operation monitoring function. User can check the information about servo easily 

with system view function and analyze the operating state of module in another way with two-dimensional trend and 

trace function. 
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1.2 Construction of Manual 
 

This manual consists of 11 chapters and appendix. 

This manual hypothesize that users execute from confirmation of positioning control system to operation in the order 

below. 

 
Sequence1  –  Install and wire positioning control system. Reference 
Install and wire PLC, servo amp, motor, external equipment and PLC such as XGT CPU, 
XPM module (XGF-PO1H, XGF-PO2H, XGF-PO3H, XGF-PO4H, XGF-PD1H, XGF-PD2H, 
XGF-PD3H, XGF-PD4H), APM module (XGF-PO1A, XGF-PO2A, XGF-PD3A, XGF-PD1A, 
XGF-PD2A, XGF-PD3A), I/O module, Specialfunction module etc 

Refer to user’s manual of 
positioning module pulse 
ouput type 

 

 

 
Sequence2  - Learn the function and working of XG-PM Reference 
Check the system can be used with XG-PM Chapter 2 
Check the function can be used with XG-PM  Chapter 3 
Install and start XG-PM Chapter 4 
Learn the operating method and the construction of monitor screen Chapter 5 

 

 

 
Sequence3  –  Execute function of XG-PM Reference 
Write a project with XG-PM Chapter 6 

 

 

 
Sequence4  –  Check the connection state of positioning module with system and the 

initial state.  
Reference 

Select a port to connect to positioning module and etc 

Chapter 7 
Check the positioning module type and module information 
Check the state of positioning module(Warning/Error) 
Check the state of servo connected to positioning module 
Check the operation of servo motor by JOG operation 

 

 

 

<To the next page> 
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<From the previous page> 

 

 

 
Sequence5  –  Set data and write into positioning module Reference 
Set parameter according to positioning control system and control method 

Chapter 8 

Set servo parameter according to servo drive, motor specification (dedicated for XGF-
PN8A) 
Execute the servo-tuning (dedicated for XGF-PN8A) 
Check positioning data through the simulation 
Check the state of positioning data by automatic error check function for setting data 

Write/Read/Compare the data set on project  Chapter 9 

 

 

 
Sequence6  –  Execute test operating and check/modify the setting Reference 
Connect to module and have module ready to execute test operating 

Chapter 10 
Check the operating state set on module through JOG operation, Direct, Indirect start and 
Speed synch. operation 
Check the state of positioning control by monitor 

 

 

 
Sequence7  –  Operate positioning control system Reference 

Operate positioning control system by PLC CPU program 
Refer to user’s manual of 
positioning module pulse 
ouput type 
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Chapter 2 System Composition 

 

This drawing describes flow of data when setting data and checking the operation status by XG-PM 

 

2.1 System Composition  



 

 

 

      Chapter Chapter 2 System Composition 
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2.2 Motion Environment 

 
XG-PM motion environment is as follows;  
 

Item Content 

Peripherals PC Using Windows PC 
CPU module CPU module corresponding to XGT CPU series 

Standard of 
motion PC 

CPU Over Pentium processor 
Memory Over 512MB 
HDD disk the least over 60MB empty space 
telecommunication
s environment RS-232C or USB  

Display Resolution of over 1024*768 
Over 64MB graphic memory  

Windows 
environment Windows 2000/XP/Vista environment 

XGT CPU 
module version 

XGK CPU Over V3.0 
XGI CPU Over V3.0 
XGR CPU Over V1.6 
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Chapter 3 Function Table 
 

3.1 Function Table 
 

Here describes important function of XG-PM. 

 

Function Content 

Support 
XGF-

POxA 

XGF-

PDxA 

XGF-

POxH 

XGF-

PDxH 

XGF-

PN8A

XGF-

PN8B

Editing 

Setting Parameter Sets common, basic, expansion, manual 
operation, homing and external signal parameter. ○ ○ ○ ○ 

Setting Operation Data 
Sets control method, operation method, 
accerelation/deceleration time, M code and 
circular interpolation data per axis unit. 

○ ○ ○ ○ 

Setting Servo Parameter 

Sets motor and actuator part, general control part, 
speed control part, didital speed and torque, 
position control part, torque control part, input 
point function, output point function and analog 
monitor parameter 

× × ○ ○ 

Setting Network Parameter 
Sets driver name, axis number, alarm information, 
alarm history information and input signal 
information of network servo drive 

× × × ○ 

Monitor 

Monitor Position Data Monitors positioning data in operation ○ ○ ○ ○ 

Monitor Operating Motion 
- Monitor Error Records 
- Monitor External Signal 
- Monitor Motion 
- Monitor Servo 

Monitors position, speed value, situation, etc of all 
axes. ○ ○ ○ ○ 

Monitors recorded error, warning, etc of all axes. ○ ○ ○ ○ 
Monitors external signal of all axes. ○ ○ ○ ○ 
Monitors motion situation of all axes. ○ ○ ○ ○ 
Monitors servo drive and motor status. × × ○ ○ 

Trand monitor Expresses positioning data in operation by graph. ○ ○ ○ ○ 

Test 

Editing positioning data Write setting parameter, operation data to module 
in operation and monitoring ○ ○ ○ ○ 

Motion 
Test 

Indirecting start Assign positioning data, step number and execute 
test. ○ ○ ○ ○ 

Directing start 
Directly sets position, speed, dwell time, M code, 
acceleration&deceleration time and tests 
positioning operation. 

○ ○ ○ ○ 

Position change Tests target position change in positioning 
operation. ○ ○ ○ ○ 

Speed change Tests speed change to axis of positioning. ○ ○ ○ ○ 

interpolation 
Edits data of linear interpolation, circular 
interpolation, elliptic interpolation, helical 
interpolation and tests. 

○ ○ ○ ○ 

Cam operation Tests cam operation from created profile by 
setting cam parameter. × ○ ○ ○ 

Step change Tests by Positioning operation after changing 
starting step of positioning operation. ○ ○ ○ ○ 

Teaching operation Tests operation of single teaching, plural teaching. ○ ○ ○ ○ 

Inching operation Tests operating designated distance per each 
operation. ○ ○ ○ ○ 

MPG operation Tests operation by manual pulse generator 
(MPG). ○ ○ ○ ○ 

Simulation Simulates motion of positioning module. ○ ○ ○ × 
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Function Content 

Support 
XGF-

POxA 

XGF-

PDxA 

XGF-

POxH 

XGF-

PDxH 

XGF-

PN8A

XGF-

PN8B

Check of 
connection Confirm connection Expresses signal from external. 

Tests initial operation by JOG operation. ○ ○ ○ ○ 

Trace 

Bit/Word Trace 
Expresses situation bit information & position 
speed information in operation. Can express 
Maximum 8 items. 

× ○ ○ ○ 

XY Trace 
Expresses position/speed information using by 2 
dimensions in operation. Can express Maximum 4 
items. 

× ○ ○ ○ 

XYZ Trace Expresses position/speed information using by 3 
dimensions in operation. × ○ ○ ○ 

Extended 
Function Cam operation Tests cam operation by created profile for 

operating cam. × ○ ○ ○ 

Printin 
Function 

Individual print Prints each setting display. ○ ○ ○ ○ 
Project print Prints whole project. ○ ○ ○ ○ 
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Chapter 4 Start & End of XG-PM 
 
 
4.1  Start of XG-PM 

 
Here describes the way of using XG-PM by windows. 
 

(1) Move cursor as follows: [Start]->[Programs]->[XG5000]->[XG-PM]. 
(2) Start [XG-PM]. 

 
   
   
 
(3) [XG-PM] will begin. 
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4.2  End of XG-PM 

 
Here describes the way of ending XG-PM. 
 

(1) Ending method by menu 
(a) Execute [Project]->[Exit]. 
(b) XG-PM is ended. 

 

          
 

(2) Ending method by title bar 

 
 

Note  
 

If it is ended without saving change after changing project data, project saving window is displayed for asking save of 
project. 
 
 
 
 
 
 
 
 
Click <Yes> button, end program with saving project. 

 Click <No> button, end program without saving project. 
 Click <Cancel> button, cancel ending program. 
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Chapter 5 Composition & the Way of Basic Using of Operation Screen 
 
5.1 Screen Composition 

 
The XG-PM screen composition is as follows; 
 
 
 

 
 
 
              <Network type XPM, standard network type XPM screen configuration> 

 

a 
b 

d 

e 

f 

h 

g 

c 
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<APM, XPM screen configuration> 
 

No. Item Description 

a Menu This is basic menu for each operation 
b Tool bar For convenience, it displays Shotcuts  

c Project window Provides some function (searching between module, add module, data copy 
between axises, etc), Can setting expository writing and password of project. 

d Command window It is easy of performance because It gathered commands for module test. 
e Input/output window Monitors input signal from external device. 
f Situation Bar Displays connecting situation and position of positioning module. 

g System view 
(operating information) 

Displays operating information of selected module. 
In case of network type module, you can check the status of the servo drive and 
motor connected to the module 

h Message window Displays each axis error & error history of selected module. 
And when module compared with data, the result data was displayed to screen. 
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5.2 The Way of Basic Using 

 
Here describes the way of basic using of XG-PM 
 
5.2.1 Menu composition  

When you select menu, commands will be displayed. Select the command with mouse or key to execute commands. 
If the menu has shortcut key, you can directly execute by shortcut key. 

    
(1) Project 

Command Description
New project Creat project first time 
Open project Open established project 

Project initialization wizard Open new project. User don’t need to write a separate data for 
operation after performing initialization wizard. 

Open APM file Read ‘*.apm’ file from APM software, convert to XG-PM project 
file (*.xpj). 

Save project Save project. 
Save other name Save the project as other name. 
Close project Close the project. 
Add item Module Add new module to project. 

Import 

Module data Read module data from file. 
CAM setting data Read setting data for creating cam profile from file. 
CAM CSV file data Read CAM profile data of CSV type 
Common parameter Read common parameter data from file. 
Operation parameter Read operating parameter data from file. 
Operation data Read operating data from file. 

Export 
Configuration file Save the selected item about setting from project window. 
CSV file Save file as CSV file form with project window. 

Print Print the activated window. 
Preview It will show you window for printing. 
Print project Print the selected project item.  
Printer Setup Select printer option. 
Recents project Display latest 20 projects. 
End End XG-PM. 
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Chapter 6 Drawing Up of Project 
 
6.1 Composition of Project 

 
Composition of project is as follows ;  
 
 

              
 
          <APM module project configuration>                     <XPM module project configuration> 
 
 

                    
   <Network XPM module project configuration>          <Standard Network XPM module project cofifuration> 

 
 

a 
b 
c 

e 
f 

g 

h 

a 
b 
c 
e 
f 

g 
h 

i 

d 

b 
a 

c 
d 

f 

e 
j 

k 

h 
g 

i 
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Chapter 7 System Check 
 
Assign the module to connect. And check the connection with the external device (serovo motor and driver) and initial 
operation. 
 
7.1 Connect PLC 

 
7.1.1 Setting Local Connection 

 
   Setting local connection can connect with RS-232C or USB. 
 
 [Sequence] 

1) Menu [Online]->[Connection setting]. 
 
 [Communication box] 

                              
 
 [Descript communication box] 

a) Type : This is setting communication media when it connect with PLC. Can set by RS-232C, USB, Ethernet, 
Model. 

b) Depth : Set connection structure with PLC. Can set Local, remote level 1, remote level 2. 
c) Connect : Try to connect with PLC by setted connection option.  
d) Settings : Can set by the way of connection which is selected a. 
e) Preview : Can confirm at a glance. About whole connection option. 
f) Timeout interval : In case that can not connect with PLC within the setted time, can retry to connect by time-

out.  
g) Retrial times : . In case that failed connection with PLC, decide how many times to retry connection. 
h) Read/Write data size in PLC run mode; Set size of data transmission frame. This option only is applied 

when PLC operating mode is ‘’RUN’, except that other operating mode send Maximum frame size.  
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(1) Local RS-232C Connection 

  
 [Sequence] 

1) Select RS-232C in the way of connection. 
2) Put the ‘Settings’ button and set communication speed, communication COM port. 
3) Put the confirm button and save communication option. 
 

 [Communication box] 

          
 

Notes  
 
1. Basic setting is setted by RS-232C, COM1 and communication speed is 115200 bps. 
2. Transmission speed suppoer 38400 bps and 115200 bps. 
3. Transmission speed of XGK series is 115200 bps. In case of connecting remote (using by Rnet), transmission 

speed is 38400 bps. 
4. Transmission port can set from COM1 to COM8. 
5. When user use ‘USB to Serial’ device, should use virtual COM port as communication port. If you need confirm 

setted port No.,please confirm device manager. 
6. XG-PM, XG-PD, Device monitor, system monitor can connect with just one PLC at the same time in XG5000. 

But, connection option have to consensus with others. 
 

 
(2) Local Connecting USB  
 

 [Sequence] 
1. Select ‘USB’ for communication method. 
2. USB has no detail setting option. Therefore, setting button will be deactivated. 
3. Put the confirm button and save connection option. 

 
Notes  
 
1. If user want to connect with PLC by USB, user need to install USB device driver. 
2. When user install XG5000, USB driver will be auto-download and install. If USB driver installation is not 

normal, please download Driver from home page of LS industrial system. 
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7.1.2  Module Connection & Confirm connection 
 
   Try to connect with PLC by setted option. 
 
 [Sequence]    

1) Select Menu [Online]->[Connect]. 
2) Communication box will be come out with connection. 

         
3) Display On-line menu and condition with connecting PLC.  
 

 
Notes  
 
1. Communication box rapidly will be come out and gone, when it success connecting with PLC.  
2. Module connection condition will be display by the side of project name and status bar after connecting with 

PLC. 
  
   [Confirm connection in the project windows] 

 
 

   [Confirm connection in the project windows] 

 
 
3. After connecting PLC, In case of connecting with other type PLC, connecting PLC automatically be 

disconnected. 
4. Monitoring will be end when it performs disconnection. 
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7.2  Confirm Module O/S Information

 
You can confirm module O/S information at the system view. 
Display version information with product of the day. 
 
 [Sequence] 

1) Select this sequence; Menu [Online]->[Connect] ; Connecting PLC (Module). 
2) Select this sequence; Menu [Online]->[Module information]. 
3) Confirm O/S information in the module information windows. 
 

 
        

 
 

Notes  
 

Display O/S version information only when module installed in that position.  
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7.3 Check Servo (Supported for Network Type XPM/Standard Network Type 

XPM) 
 

You can check the servo through the “System view” screen. 

 

[Sequence] 
1) Click menu [Online]  [Connect] and connec to PLC (module) 
2) Check the module connection status of the project window 

(To check the servo information, the module should be “online” status.) 

 
3) Click menu [Online]  [Connect to all servos] and connec to the servo drive. 
4) Check the servo information at the “System view” screen. 
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  [Dialog box] 

 

 
 

 [Dialog box description] 
a) Motor ID : shows the motor ID of the currently selected axis. 
b) Driver ID : shows the servo drive ID of the currently selected axis. 
c) Encoder ID : shows the encoder ID of the currently selected axis. 
d) Encoder pulse count : shows the encoder pulse count for the currently selected axis. 
e) Pulse count per rotation : shows the pulse count per rotation for the currently selected axis  
f) OS Version: shows OS version of a servo 
g) Apply parameter : decides whether to apply the data from the current axis to basic parameter and servo 

parameter.  
h) Servo axis description : shows servo axis description and you edit servo axis description (But, servo axis 

description is not saved at the module or servo, that is saved at the only project file.) 

 

 
Note  

 
You can check the servo information on the only one axis specified by the user. 

 

 

 

 

 

 

 

a 

b 

c 
d 

e 

f 

g 

h 
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Chapter 8 Setting Data 
 
Here describes setting data of positioning module. 
 

8.1  Setting Common Parameter 
 
 [Sequence] 

1) Double-click [Common parameter] in the project tree.  
2) Click the cell which you want to set and input data. 

 
 [APM module Setting screen] 
 

           
 
 [Setting screen description] 

a) Setting pulse output level, Circular interpolation, encoder input and Auto Reload 
b) Setting ZONE output module and ZONE axis 
c) Setting ZONE ON and OFF region  

 
[XPM module Setting screen] 

 

    
 
 [Setting screen description] 

a) Encoder input mode and setting pulse output level.  
b) Setting encoder input range. 
c) Setting speed override unit. (Designate % or Can designate speed input value.) 

 

a 

b 

c 
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[Network type XPM module, standard network type XPM module setting screen] 

    

 
  

[Setting screen description] 
a) Encoder 1,2 input mode and setting whether to use “z-phase clear” 
b) Encoder 1,2 input range setting 
c) Speed override unit setting (% or speed) 

a 

b 

c 
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8.2  Setting Operation parameter  
 
    [Sequence] 

1) Double-click [Axis #X~Z data]->[Parameter] in the project tree. (APM module)  
Double-click [Axis #1~4 data]->[Parameter] in the project tree. (XPM module) 
Double-click [Axis #1~8 data]->[Parameter] in the project tree.  
(Network type XPM module, standard network type XPM module) 

2) Click cell which you want to set and input data. 
 [Setting screen] 

 
 [Setting screen description] 

a) Basic parameter : Set basic parameter for operating.  
b) Extended parameter : Set expansion parameter.  
c) Manual operation parameter: Set parameter for manual operation. 
d) Homing parameter: Set parameter when it is homing. 
e) I/O signal parameter: Set contact type of external signal (contact A or contact B). 

a 

b 

c 

d 

e 
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8.2.1  Setting detailed parameter 
   XG-PM provides setting parameter function for convenient setting operation parameter. User can set operation parameter by help 

of each parameter. 
 
 [Sequence] 

1)  Double-click [Axis #X~Z data] [Parameter] in the project tree. (APM module)  
Double-click [Axis #1~4 data] [Parameter] in the project tree. (XPM module) 
Double-click [Axis #1~8 data] [Parameter] in the project tree. (Network type module) 

2)  Progress this sequence; Menu [Edit]->[Detail parameter setting ].  
3) Set parameter in the communication box of setting detail parameter. 
 

 
 [Communication box] 

 
 
 [Communication box description] 

a) Parameter : Display parameter Display parameter according to each group. Select each cell and set parameter.  
b) Axis & Parameter move to between groups : Provide item list for convenient moving between groups. Then, detailed 

screen also will be new according to moving between groups. 
c) Display data range : Set range of selected parameter data. 
d) Moving group button: Set that was displayed moving between groups of parameter screen. Then, detailed screen also 

will be new according to moving between groups. 
e) Detail description : Provides help about each item of set parameter. 

 
Notes  
 

Application of editing data : Set detail parameter data, only put the [Confirm] button of communication box, can apply editing data. Put 
the [cancel] button, will not be applied set data. 
 

a 

c 

b 

e 

d 
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8.2.2  Detail View/Simple View 
 

Use menu (positioned on the top of the operation parameter screen) and provides function (detail view /simple view). 
If user want more detail, Select [detail view] and set parameter. 
 

 
 [Sequence] 

1) Revitalize operation parameter screen. 
2) Click [Item] on the upper end. 
3) When user clicks [item], dropdown menu will be come out. And User can select detail view /simple view.  
4) Select menu (detail view /simple view) and perform.  
 

 [Setting screen] 
 

                  
 
 [Setting screen description] 

a) Detail view /Simple view :  
Detail view: Display all parameter on the screen. 
Simple view: Display parameter which is necessary parameter for operating.  

a 
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8.2.3  Setting Input/Output signal parameter (only applied to XPM, APM module) 
 

Provides function (Setting input/output signal parameter at a time.) for convenient (setting easily parameter of input/output signal).  
In case that check input/output signal parameter,  
When user checks input/output signal parameter, it can be set parameter several of axis at a time. If user didn’t check the check box, 
it can be set only one. 

 
 
[Setting screen] 
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8.3 Setting Servo Parameter  

(Only applied to Network Type XPM/Standard network type XPM) 
 

 [Sequence] 
  

1) Double-click [Axis #1~8 data] [Servo Parameter] in the project tree.  
2) Input data after clicking the shell you want to set up. 

 
 [Setting screen] 
 
           [Network XPM setting screen] 
 
 

 
 
 
           [Standard network XPM setting screen]  
 

 
 

a 

b 

c 

d 

e 

a 

c 

f d g h 
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[Setting screen description] 

a) Servo parameter type : shows specific parameter group  
b) Axis display : shows the axis under edition  
c) Data setting screen : sets up the data 
d) Servo parameter change during operation: sets up whether to apply the servo parameter change during operation. If 

checked, the currently set data will be written to the module   
e) Read only parameter : the data that should be not edited by the user is displayed with gray background  
f) Current value : shows current value of the servo parameter. 
g) Initial value : shows initial value of the servo parameter. 
h) Access : shows ‘Read/Write’ property of the servo parameter. 

 

8.3.1  Detailed Parameter Setting  
XG-PM software provides “detail parameter setting” function so that the user can set up the operating parameter easily. You can set 
up the servo parameter easily referring to the detailed description of each parameter item. 

 
 [Sequence] 

1)  Double-click [Axis #1~8 data] [Servo Parameter] in the project tree.  
2)  Click menu [edit]  [Detail parameter setting] 
3)  Set up the parameter at the [parameter detailed setting dialog box] 
 

 [Setting screen] 

 
 
 
 
 [Setting screen description] 

a) Parameter : shows parameter group. Select the each shell and set up the parameter   
b) Axis and parameter group shift : provides item list so that you can easily move between groups and axes of the 

parameter. At this time, detailed description screen refreshes automatically.  

a 

b 

c 

e 

d 
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c) Data range : shows the data range of the currently selected parameter item. 
d) Group shift button : moves between parameter groups. At this time, detailed description screen refreshes automatically. 
e) Detailed description : provides detailed description on each parameter item. 

 

8.3.2  Individual Writing of the Servo Parameter  
XG-PM software package provides “Individual Writing of the Servo Parameter” function so that you can modify and check the servo 
parameter individually.  

 
 [Sequence] 

1)  Double-click [Axis #1~8 data] [Servo Parameter] in the project tree.  
2)  Check “Allow Servo Parameter (Individual) Change during Operation” at “Servo parameter change during operation” 
3)  After modifying the shell, press “Enter” key or cancel the cursor from the current shell 
 

 
Tip  

 
Condition for “Servo parameter change during operation” 
- The module should be “Online” status, and servo axis should be connected to the module. If not, “Servo parameter change 

during operation” is not activated.  
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8.3.3 Servo Parameter Display Method (Only applied to standard network type XPM) 
 

XG-PM software provides two ways of decimal and hexadecimal display to express the number for user convenient.   
 
[Sequence] 

1) In project tree, double-click [#1~8 Axis data]  [Servo Parameter]. 
2)  In data setting screen, after clicking the right mouse button, click [Decimal Display] or [Hexa Display] menu. 

 
[Setting screen] 

 

 

[Setting screen description] 
a) [Decimal Display]/[Hexa Display]: [Decimal Display] displays all current value and initial value of the servo parameter as 

decimal number and [Hex Display] displays all current value and initial value of the servo parameter as hexadecimal. 
 

 

8.3.4 Saving Servo Parameter at EEPROM (Only applied to XPM type) 
 

XG-PM software package provides a function to save the servo parameter at EEPROM 
 
 

[Sequence] 
1) Set the servo parameter 
2) Press [Online]  [Save Servo Parameter to EEPROM] 
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8.4  Setting Position Data 
 
 [Sequence] 

1)  Double-click [Axis #X~Z data] [Position data] in the project tree. (APM module)  
Double-click [Axis #1~4 data] [Position data] in the project tree. (XPM module) 
Double-click [Axis #1~8 data] [Position data] in the project tree. (Network type XPM, standard network type XPM) 

2) Input data after selecting cell which you want to set. 
 

 [Setting screen] 
 

 
 
 [Setting screen description] 

a) Display axis : Show you axis that it is setting. 
b) Display step : Display the number of operation steps.  
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8.4.1 View in detail/simple 
 

It provides function (detail view/simple view) by menu where it is positioned at the top of operation screen. If user set only 
elementary factor of operation data by function (detail view/ simple view), user can select simple view for setting operation data. If 
user wants for more detail setting, user can select detail view for setting operation data.    

    
 [Sequence] 

1) Revitalize operation data screen. 
2) Click [#X~axisY] of the top of screen. (APM module) 

Click [#1~axis4] of the top of screen. (XPM module) 
Click [#1~axis8] of the top of screen. (Network type XPM, standard network type XPM) 
When click [#1~axis4], drop down menu will be appeared and can see menu (detail view/simply view). 

3) Select detail view or simply view and execute. 
 
 [Setting screen] 

 
 [Description of setting screen] 

b) Detail view/Simple view : Detail view display editing item of whole operation data. Simple view display elementary item of 
the operation data. 

 
Notes  

 
This is the displayed item of operation data at the screen when select detail view menu. 
<XPM module> 
 
 
 
< APM module> 
 
 
 
This is the displayed item of operation data at the screen when select simply view menu. 
<XPM module> 
 
 
 
<APM module> 
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8.5 Network Parameter Setting (Only applied to standard network type XPM) 
 

[Sequence] 
1) In project tree, after clicking [Network Parameter], click right mouse button and click [Add Item]  [Drive]. 
2) In servo information dialog box, set up driver name and axis number and click OK  

[Setting screen] 

 
 
[Servo Information dialog box] 

 
 
 
 
[Dialog description] 

a) Drive name : selects the device and displays device name. 
b) Axis No. : inputs axis no. of the selected device. 
c) Vendor : shows maker name of the selected device. 
d) Group : shows type of the selected device. 
e) Version : shows the version of the selected device. 
f) Description : inputs servo information description. 
g) OK : ends the dialog box. After ending the dialog box, servo information is saved. 
h) Cancel : ends the dialog box. 

 

a 
b 
c 
d 
e 
f 

g h 
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8.5.1 Servo drive Selection 
[Sequence] 

1) Click ‘ ’ on the servo information dialog box. 
2) Select the device in the servo drive selection dialog box and click OK. 

 
[Servo Information Dialog Box] 

 
[Dialog description] 

a) Classification: by using this item list, you can see the applicable group at the driver selection screen. 
b) Drive selection: selects the drive. 
c) Detail info.: shows detailed information of the selected device. 

 
 
Note  
 
Device information shown at the servo drive selection dialog box is in “Drive Info” folder of the XG-PM installation path.  
When adding new device, save xml file provided from the maker in Drive Info folder and restart XG-PM. 
 

 
 

a 

b 

c 
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8.5.2  Modifying Servo Setup Information 
Servo setup information has object information on alarm information/ alarm history information/ input signal information. That 
information is not defined by xml file of the device maker and set up automatically when adding the servo drive. If servo setup 
information doesn’t coincide with actual device, there may be limits on using the device. So you have to modify the servo setup 
information. 

 
 [Sequence] 

1) Select the servo configuration tap in the Servo Info. dialog box. 
2) In the servo configuration tap, select item you want to modify and double-click it. 
3) In the object selection dialog box, select object you want to modify and click OK. 

 
[Servo information dialog box] 

 
[Dialog box description] 

a) Alarm: shows object on alarm information. 
b) Alarm history information: shows object on alarm history information. 
c) Input signal: shows object on input signal information. 
d) Use: selects whether to use applicable servo information 

 
[Servo information dialog box] 
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8.5.3  Up/Down Network Parameter 
[Sequence] 

1) After clicking [Network Parameter] in the project tree, select the drive you want to move 
2) After click right mouse button, click [Move down] or [Move up] menu. 

 
 
[Setting screen] 

 
 

 
Note  
 
Sequence of network parameter should coincide with physical connection sequence of the network drive.  
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8.6 Servo Station Setting  

(Only applied to Network Type XPM, Standard network type XPM) 
 

[Sequence] 
1) Activate the “System view” screen 
2) Locate the mouse cursor on the servo drive you want to set up the station and click the right mouse button. And click 

“Servo station setting” menu. 
3) Set up the servo station at the servo station setting dialog box and press OK button  

 
 [Setting screen] 

   
 
[Servo station setting dialog box] 
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8.6.1  Auto Detection of Duplicated Servo Station 
Servo station can be set by software setting in the XG-PM software package. When setting the servo station, since there is “Auto 
Detection of Duplicated Servo Station” function, you can prevent duplicated servo station setting. If there is duplicated servo station, 
the following warning message shows.   

 
 

 
   

If you press “Yes”, the existing station changes in to current station. If not, it keeps current station. 
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8.7  Setting Electronic CAM  

(only applied to XPM, Network type XPM, Standard Network type XPM) 
  
XG-PM provides function of creating profile for operating electronic CAM. 
 
 [Sequence] 

1) Double click [CAM data] on the project tree.  
2) Setting CAM block number what you want. 
3) Setting CAM control mode. Then setting unit of point. 
4) Set the principal axis/the sub axis. Set CAM block data depends on this standard. 
5) Set CAM block data.  

 
 [Setting screen] 

 
 [Description of setting screen] 

a)  Select CAM block : Setting CAM data block what you need to set. CAM data block can be set from no.1 to no.8. 
b)  Setting CAM control mode : Set control method & point unit of CAM data. Select repeat mode of control method when              

creating profile. (But, not increase direction and when create repeated profile). 
Select increasing mode when creating CAM profile which is increased to one-way. 
 

 
c)  Setting CAM block data : Set CAM block data depends on setting CAM control mode and the principal axis/ the axis of  

ordinates of parameter.   
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Start position of the principal axis: Set the position which main axis is began on the current step. When set main ax. end 
position, next main ax. start position also to be set automatically.  
But, if the last position of main axis is set, start position of main axis not to be set automatically.  
Last position of main axis : Set the last position for movement of main axis. Set to maximum last position of main axis. 
Start position of sub axis: Set the position which the sub axis is begun on the current step. 
When set sub ax. end position, next sub ax. start position also to be set. 
But, if the last position of the sub axis is set to maximum position, start position of the sub axis not to be set automatically. 
Last position of the sub axis: Set the last position for movement of the sub axis. Set the last position for movement of the 
sub axis on the current step. Can set it to the last position of the sub axis. 
CAM curve: Set the type of CAM curve for application on the current step. XG-PM support total 22 type of CAM curve. 

  
d)  Setting the principal axis/the sub axis parameter: Set the data for positioning several *axis with CAM operation. 

Then, the data which is meaning last position of the *axis is as follow. And the axis position is depends on setting unit of 
*axis. (*axis: the principal axis/ the sub axis) 

 
In case that pulse is unit of axis (the principal axis/ the sub axis): [the number of pulses per rotation] The value to be 
maximum last position of axis (principal axis/the sub axis) 
In case that mm/inch is unit of axis (the principal axis/ the sub axis): [travel distance per rotation] The value to be maximum 
last position of axis (principal axis/the sub axis) 
In case that degree is unit of the principal axis: 360.00000 is the maximum last position of the principal axis. (The sub axis 
has not unit degree) 

  
e) Special character curve button: Special character curve communication box to be revitalization when put this button.   
f) Setting complete button: Create profile as set CAM block data up to now.  

. 

8.7.1  Confirm of CAM special character curve 
Can set XG-PM after confirm CAM special character curve before set electronic CAM operation. 

 [Communication box] 

           
 
 [Communication box description] 

a) CAM characteristic curve: Select type of CAM curve what you need to confirm. Support total 22 type of curve. 
b) Position/Speed/Acceleration/Jerk (SVAJ) graph: Display characteristic curve of position/Speed/Acceleration/Jerk of 

selected CAM curve by each graph. And then in case of setting maximum value as “1”, can confirm value of 
maximum/minimum.  
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8.7.2  Confirm CAM graph 
User can confirm CAM profile by CAM parameter which is set by user on the graph screen of CAM data screen  
It is possible that user confirm CAM profile which is made by CAM parameter as data value on the graph and each point. 

    [Sequence] 
1) Revitalize CAM data screen. 
2) Set CAM data on the parameter screen. (refer to this manual 8.6) 
3) Put the setting complete button. 
4) Put setting complete button, automatically change to graph screen with this picture.  
 (But, this picture will be disappeared automatically. 

 
 

5) Confirm Cam profile which is set by user of CAM block.  
 [Graph tab screen] 

 
 [Graph tab screen description] 

a) CAM profile: Display created result data after setting CAM profile. Display position of main axis/position of the sub 
axis/speed of the sub axis/acceleration of the sub axis/Jerk of the sub axis. 

b) CAM graph: Position of sub axis is displayed by axis X. The values of sub axis Position/Speed/Acceleration/Jerk are 
displayed by axis Y. 
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8.7.3 Edit CAM profile (Supported at V1.1 or above) 
After setting the CAM profile by CAM parameter, you can modify the CAM profile (sub axis position) finely. Namely, you can modify 
the error that occurred during operation. 

 
 [Sequence] 

1)  Revitalize CAM data screen. 
2)  Set CAM data on the parameter screen.  
3) Put the setting complete button. 
4) Put setting complete button, automatically change to graph screen with this picture.  
 (But, this picture will be disappeared automatically. 

 
 

5) Confirm Cam profile which is set by user of CAM block. 
6) Edit the sub axis position  
7) After download, check the profile through trial-run or cam profile graph  
8) Repeat step 6)~7) and create the CAM profile you want  

 [Graph tab screen] 

 
 [Graph tab screen description] 

a) CAM profile: Display created result data after setting CAM profile. Display position of main axis/position of the sub 
axis/speed of the sub axis/acceleration of the sub axis/Jerk of the sub axis. 

b) CAM graph: Position of sub axis is displayed by axis X. The values of sub axis Position/Speed/Acceleration/Jerk are 
displayed by axis Y. 
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8.8  Simulation 
 
XG-PM provides simulation function that it is confirm performance of positioning module before operation. 
 

8.8.1 Execution of Simulator (only applied to XPM, network type module) 
[Sequence] 

1) Execute Menu[Project]->[New project], create project or execute Menu[Project]->[Open project], open project for 
simulation. 

2) Menu [Instrument]-> [Starting simulator]. 
3) Confirm Module information of simulator, OS information, Scan time. 
4) Confirm performance of positioning module. 
5) End simulation by following proceed : Menu [Instrument]->[Simulator End]  

 
[Communication box] 

    
        <XPM module simulator dialog box>                      <Network type simulator dialog box> 

 
[Explain communication box] 

a) Module information: Simulator display module. 
b) OS information: Simulator display OS information of simulating module. 
c) Scan time: Display cycle of performing command. 
d) Setting button of external I/O: Can confirm value of external input/output signal and can set value of external IO.  
e) Axis information of external I/O: Display axis information of external I/O. 

 
 

Note  
 
Simulator can simulate for only a module. Simulator cannot perform with over 2 project module. 
Connecting option of situation bar is displayed as “Simulator” while simulator is operating. 
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8.8.2 External I/O setting of Simulator (only applied to XPM, network type module) 
External I/O setting screen of simulator only display ON/OFF of external input/output signal regardless of I/O signal HIGH/LOW.  
External I/O can be set by click the I/O button of pertinent axis.  
 

 
 
[External I/O description] 
U.Limit : Upper limit signal 
L.Limit : Low limit signal 
DOG : Approximate origin signal 
HOME :Origin signal 
EMG : Emergency stop signal 
VTP : Speed/Position control conversion signal 
DRV : Drive ready signal 
INP : In position signal 
CLR : Clear signal 
 

Note  

Drive ready signal is set as “ON” for convenient. All of the initial status of signal is “OFF” except for drive ready signal. 

8.8.3  Simulator screen control function (only applied to XPM, network type module) 
Simulator provides screen position movement and hides function of external I/O setting button for convenient. 
 
(1) Screen position movement 

[Sequence] 
Click screen movement mark at the corner of simulator screen. 
 
[Communication box] 

 
 

[Explain communication box] 
a) Left top corner movement: Simulator move to left top corner movement of XG-PM. 
b) Right top corner movement: Simulator move to right top corner movement of XG-PM. 
c) Left bottom corner movement: Simulator move to left bottom corner movement of XG-PM. 
d) Right bottom corner movement: Simulator move to right bottom corner movement of XG-PM. 

 

Upper limit signal is on 

Upper limit signal is off 
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(2) Hiding external I/O setting button 
 

[Sequence] 
Click hiding mark of external I/O setting button on the simulator screen. 

 
 

(3) Displaying external I/O setting button 
 
When external I/O setting button was hided, click showing mark for external I/O setting of simulator screen. 

 
 

8.8.4 Sight of simulator support function (only applied to XPM, network type module) 
 

Simulator can simulate only one module. The function is as following: 
 

(1) Project management function 
Function Feasible or not 
New project O 
Open project O 
Project initialization wizard X 
Open APM file X 
Save project O 
Save as O 
Close project O 
Add item X 
Import O 
Export O 
Print O 
Preview O 
Printing project O 
Setting project O 
The latest project O 
Exit O 
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(2) Online & Connecting module function 

Function Feasible or not 
Connect/ Disconnect X 
Connection setting X 
Write O 
Read O 
Compare with module O 
Module initialization O 
Online model setting X 
Module information O 
Download O/S  X 
Operation command O 

Pause axis monitor O 

 
(3) Command function 

Function Detail command Feasible or not 
Basic Command Error reset O 

Indirect starting O 
Direct starting O 
Deceleration stop O 
Inching operation O 
Jog operation O 
Jog stop O 

Expansion 
command 

Speed synch O 
Position synch O 
Positioning speed synch O 
CAM operation O 
Ellipse interpolation O 
Start at the same time O 

Changing 
command 

Position override O 
Speed override O 
Positioning speed 
override 

O 

Current position preset O 
Encoder preset O 
Starting step O 
Repeating step O 

Teaching 
command 

Plural teaching 
/ Teaching value 

O 

Point command Point operation O 
Tool bar command Function command O 
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(4) Monitoring function 

Function Feasible or not 
Start monitoring O 
Axis monitor pause O 
System view monitoring O 
Trend monitoring O 
Data Trace O 
External I/O Monitoring O 

 
(5) Other function 

Function Feasible or not 
Multi module online X 

 

8.8.5 Profile simulation (only applied to APM module) 
 [Sequence] 

1) Input data to the operation data item of axis to simulate. 
2) Execute [Tools]  [Profile/Circular interpolation simulation] 
3) Select [Profile Simulation] tap in the communication box. 
4) After setting simulation axis and step number in the simulation communication box, press the [Run Simulation] button. 

 
 [Communication Box] 
 
 

 
  
 
 
 

e 

a 

b c 

d 

Time 

Sp
ee

d 
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[Explain communication box] 
a) Axis : sets target axis for profile simulation. 
b) Simulation state : displays current simulation state 
c) Start step number : sets step number of axis for profile simulation 
d) Run simulation : runs profile simulation 
e) Close : Closes profile and circular interpolation simulation communication box. 

 
Note  

 
Profile simulation is available for only one axis. Operations using 2 axes such as interpolation operation can not be simulated  
 

 

8.8.6  Circular interpolation simulation (only applied to APM module) 
 [Sequence] 

1) Input data to the operation data item of axis to simulate. 
2) Execute [Tools]  [Profile/interpolation simulation] 
3) Select [circular interpolation] tap in the communication box. 
4) After setting axis and step number in the simulation communication box, press “Run Simulation” button. 

 
 [Communication box] 

 

 
  

[Explain communication box] 
a) Circular interpolation environment setting : sets method and direction of circular interpolation 
b) Main axis information : sets main axis of circular interpolation (horizontal axis information) 
c) Sun. axis information : sets sub axis of circular interpolation (vertical axis information) 
d) Run Simulation : runs circular interpolation simulation 
e) Close : closes profile and circular interpolation simulation communication box. 

 

a 

b 

c 

e 

d 



 

 

 

 

 

Chapter 9 Write/Read/Comparison data 

 

 

    

9-1 

Chapter 9 Write/Read/Comparison data 
 

9.1  Write data 
 
Send Cam setting data/operation parameter/operation data to module. 
 

[Sequence] 
1) Select “Menu [Online]->[Connect]” connect with module and online. 
2) Select “Menu [Online]->[Write]” 
3) Select data and confirm for sending to module. 
 

[Communication box] 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
                <APM>                                      <XPM>            
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
          <Network type XPM>                       <Standard network type XPM> 

a 

d e 

b 
c 

a 

a 

b 
c 

c 
b 

d e 

d e 

a 

d e 

b 
c 
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[Explain communication box] 

a) Select tree: Select data for sending to module. 
b) All axes setting: select the module for all axes setting per each item  
c) All axes setting item: select the item for all axis setting. When selecting the item, all items are set for the selected module 
d) Confirm button: Begin to send data to module with confirm button. 
e) Cancel button: Stop writing with cancel button. 
 

 
 

Note  
 
1. Cannot use corresponding data while it is operating. 

(Operation data/Operation parameter) 
2. Common parameter and CAM data (only applied to XPM module) can be written while it is operating. 
3. All axes setting function is supported at XG-PM V1.2 or above. 
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9.2  Read data 
 
Read CAM setting data/operation parameter/operation data from selected online module by user. 
 

[Sequence] 
1) Select “Menu [Online]->[Connect]” connect with module and online. 
2) Select “Menu [Online]->[Read]”. 
3) Select data and confirm for reading data from module. 

 
[Communication box] 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
               <APM module>                               <XPM module>                    
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

<Network type XPM>                      <Standard network type XPM> 

a 

d e 

b 
c 

b 
c 

a 

a 

d 

d 

e 

e 

b 
c 

a 

b 
c 

d e 
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[Explain communication box] 

a) Select tree: Select data which it is red from module. 
b) All axes setting: select the module for all axes setting per each item  
c) All axes setting item: select the item for all axis setting. When selecting the item, all items are set for the selected module 
Confirm button: Begin to read data from module with confirm. 
d) Cancel button: Stop reading with cancel button. 
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9.3  Comparison Data 
 
Read CAM setting data/ operation parameter/ operation data from selected online module by user, compare with project data and 
display the result on the screen. 
 

[Sequence] 
1) Select “Menu [Online]->[Connect]”connect with module by online. 
2) Select “Menu [Online]->[Compare with module]”. 
3) To compare the module and data, select the target data and press OK. Then it reads the selected data from the module 

and shows comparison result at [Compare with Module] window. 
 

[Communication box] 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
                   <APM>                            <XPM>                      
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
              <Network type XPM>          <Standard network type XPM> 

a 

d e 

b 
c 

a 

b 
c 

d e 

a 

b 
c 

d e 

a 

b 
c 

d e 
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[Communication box description] 

a) Select tree: Select comparison data which data is compare with project data on the module. 
b) All axes setting: select the module for all axes setting per each item  
c) All axes setting item: select the item for all axis setting. When selecting the item, all items are set for the selected module 
d) Confirm button: Begin to read data with confirm. 
e) Cancel button: Stop to read with cancel button. 
 

Note  
The data comparison result is displayed on the [Compare with module] of message window. 
 
 
 
 
 
 
 
 
 
                        <APM>                                      <XPM, Network type module> 
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Chapter 10 Test Run by XG-PM 
 
Here descript about test running XG-PM. 
 

10.1  Composition of a Picture of Test Run 
 
 

10.1.1  Composite command screen 
Command screen is composite by 5 tab (Basic command/ Expansion command/ Conversion command/ Teaching command/ 
Point command). Basic composition of command screen is as following: 
 
[Composition of a picture] 
 

 
[Screen explanation] 

a) Data setting: Set the data which user wants to command.  
b) Conversing command tab: User can select what he wants to use within command screen. 
c) Action button: Operate with action button. 
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10.1.2  System View 
XG-PM provides module and servo status with one screen of system view. User can easily confirm operation status of each axis, 
encoder value, servo address (network type XPM, standard network type XPM) and system information (network type XPM, 
standard network type XPM) by system view screen.   
 
[Composition of a Picture] 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

                     <APM>                                                      <XPM> 
 

 

 
                 <Network type XPM, standard network type XPM> 

a 

b 

c 

a 

b 

c 

c d 

e 

b 
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[Screen description] 

a) Monitoring revitalization check box: Revitalize (check)/not Revitalize (uncheck) function of operation status confirm. 
b) Display operation status of each axis: Display operation status of each axis.  
c) Display encoder value: Display current encoder value on the screen. 
d) Display servo status: Display the operation status of the connected servo 
e) Display system information: Display information of the connected module. Module position, module information, module 

O/S version and module error status  
 

Notes  
 

If cancel monitoring revitalizing check box, XG-PM load can be decrease. 
 

 
 

10.1.3  Screen of External Input/Output Signal 
External input/output signal screen displays signal status that it is inputted from outside.  

 
[Composition of a Picture] 

    
                      <APM>                                                   <XPM> 
 

     

                  <Network type XPM>                                <Standard network type XPM> 
 



 

 

 

 

 

Chapter 10 Test run by XG-PM 
 

 

 10-4 

 

10.1.4  Error Message Screen 
Display error status and error record of each operating axes.  

 
[Composition of a picture] 
 
 
 

 
 
 
 
[Composition of a Picture] 

a) Axis: Display erroneous axis. 
b) Code: Display error code. 
c) Error explanation: Display detailed explanation of error. 
d) Error Fix Description: Display error fix description for cancel error. 
e) Error status: Display the latest error. (Display standing in line from axis 1 to axis 4.) 
f) Error record: Display error record of each axes. (Can display max 10 for each axes, display standing in line from axis 1 to 

axis 8(X~Z aixs).) 
 
 

a b c d 

e f 
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10.2  Test Run Mode 
 
 
Here describes test run of positioning module by XG-PM. 
 

10.2.1  Select Operation Command Axis 
 

[Composition of a picture] 

 
[Explanation of screen] 

a) Select command module: Select module for command. 
b) Select command axis: Select axis for command. 

 

10.2.2  Implementation 
 

Operate command to selected axis at 10.2.1, when command. 
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10.2.3  Test Run 
(1)  Basic command  

        ① APM module (XGF-POxA, XGF-PDxA) 

Screen Command Setting range Related 
Command

Error Reset  Axis error reset, Axis error reset/Enable output CLR 
Indirect Start  Step : 1 ~ 400 IST 

Direct start 

1. Position (each Unit range) 
pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 

inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 
2. Speed (each Unit range) 

pulse  : 0 ~ 1,000,000 [pulse/sec](XGF-PDxA) 
pulse  : 0 ~ 200,000 [pulse/sec](XGF-POxA) 
mm : 0 ~ 2,000,000,000 [X10-2 mm/min](XGF-PDxA) 
mm : 0 ~ 2,000,000,000 [X10-2 mm/min] (XGF-POxA) 
inch : 0 ~ 2,000,000,000 [X10-3 inch/min](XGF-PDxA) 
inch : 0 ~ 2,000,000,000 [X10-3 inch/min](XGF-POxA) 
degree : 0 ~ 2,000,000,000 [X10-3 degree/min](XGF-PDxA) 
degree : 0 ~ 2,000,000,000 [X10-3 degree/min](XGF-POxA) 

3. Dwell : 0 ~ 50,000 ms 
4. M code : 0 ~ 65,535 

DST 

Deceleration 
stop 

Stop time : 0 ~ 65,535 ms 
STP 

Inching 
operation 

Amount of Inching : -2,147,483,648 ~ 2,147,483,647 pls 
INCH 

Jog 
Operation 

/Stop 
 

Speed (each Unit range) 
pulse  : 0 ~ 1,000,000 [pulse/sec](XGF-PDxA) 
pulse  : 0 ~ 200,000 [pulse/sec](XGF-POxA) 
mm : 0 ~ 2,000,000,000 [X10-2 mm/min] (XGF-POxA, PDxA) 
inch : 0 ~ 2,000,000,000 [X10-3 inch/min] (XGF-POxA, PDxA) 
degree : 0 ~ 2,000,000,000 [X10-3 degree/min]  
(XGF-POxA, PDxA) 

- 
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        ② XPM module (XGF-POxH, XGF-PDxH) 

Screen Command Setting range Related 
Command

Error Reset  Axis error reset/Common error reset XCLR 
Indirect Start  Step : 1 ~ 400 XIST 

Direct start 

1. Position (each Unit range) 
pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 

inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 
2. Speed (each Unit range) 

pulse  : 0 ~ 4,000,000 [pulse/sec](XGF-PDxH) 
pulse  : 0 ~ 500,000 [pulse/sec](XGF-POxH) 
mm : 0 ~ 2,000,000,000 [X10-2 mm/min] 
(XGF-POxH, XGF-PDxH) 
inch : 0 ~ 2,000,000,000 [X10-3 inch/min] 
(XGF-POxH, XGF-PDxH) 
degree : 0 ~ 2,000,000,000 [X10-3 degree/min]  
(XGF-POxH, XGF-PDxH) 

3. Dwell : 0 ~ 65,535 ms 
4. M code : 0 ~ 65,535 

XDST 

Deceleration 
stop 

Stop time : 0 ~ 2,147,483,647 ms 
XSTP 

Inching 
operation 

Amount of Inching : -2,147,483,648 ~ 2,147,483,647 pls 
XINCH 

Jog 
Operation 

/Stop 
 

Speed (each Unit range) 
pulse  : 0 ~ 4,000,000 [pulse/sec](XGF-PDxH) 
pulse  : 0 ~ 500,000 [pulse/sec](XGF-POxH) 
mm : 0 ~ 2,000,000,000 [X10-2 mm/min]  
(XGF-POxH, XGF-PDxH) 
inch : 0 ~ 2,000,000,000 [X10-3 inch/min]  
(XGF-POxH, XGF-PDxH) 
degree : 0 ~ 2,000,000,000 [X10-3 degree/min]  
(XGF-POxH, XGF-PDxH) 

- 
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③ Network type XPM (XGF-PN8A), standard network type XPM (XGF-PN8B) 

Screen Command Setting range Related 
Command

Error Reset  Axis error reset/Common error reset XCLR 
Indirect Start  Step : 1 ~ 400 XIST 

Direct start 

1. Position (each Unit range) 
pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 

inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 
2. Speed (each Unit range) 

pulse  : 0 ~ 10,000,000 [pulse/sec]  
mm : 0 ~ 2,000,000,000 [X10-2 mm/min] 
inch : 0 ~ 2,000,000,000 [X10-3 inch/min] 
degree : 0 ~ 2,000,000,000 [X10-3 degree/min] 

3. Dwell : 0 ~ 65,535 ms 
4. M code : 0 ~ 65,535 

XDST 

Deceleration 
stop 

Stop time : 0 ~ 2,147,483,647 ms 
XSTP 

Inching 
operation 

Amount of Inching : -2,147,483,648 ~ 2,147,483,647 pls 
XINCH 

Jog 
Operation 

/Stop 
 

Speed (each Unit range) 
pulse  : 0 ~ 10,000,000 [pulse/sec] 
mm : 0 ~ 2,000,000,000 [X10-2 mm/min] 
inch : 0 ~ 2,000,000,000 [X10-3 inch/min] 
degree : 0 ~ 2,000,000,000 [X10-3 degree/min] 

- 
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(2)  Extension command 

        ① APM module (XGF-POxA, XGF-PDxA) 

Screen Command Setting range Related 
command

 

Speed sync. 
1. Main axis range : Axis X~  Axis Z and Encoder 
2. Main axis rate : 1 ~ 65535 
3. Sub axis rate : 1 ~ 65535 

SSS 

Position sync. 

1. Step : 1 ~ 400 
2. Position (each Unit range) 

pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 

inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 
3. Main axis range : Axis X~ Axis Z and Encoder 

SSP 

Speed sync. 
with position 

1. Main axis range : Axis X~  Axis Z and Encoder  
2. Main axis rate : 1 ~ 65535 
3. Sub axis rate : 1 ~ 65535 
4. Position (each Unit range) 

pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 

inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 

SSSP 

Linear 
interpolation 

1. Axis: Axis X, Axis Y/Axis X, Axis Z/ Axis X, Axis Y, Axis Z 
2. Step : 1~400 

LIN 

Circular 
interpolation 

1. Step : 1~400 
2. Sub axis: Axis X ~ Axis Z 

CIN 

Synch start  Axis : Select X ~ Z axis, Step No.: 1 ~ 400 SST  
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        ② XPM module (XGF-P0xH, XGF-PDxH) 

Screen Command Setting range Related 
command

 

Speed sync. 
1. Main axis range : Axis 1 ~  Axis 4 and Encoder 
2. Main axis rate : 1 ~ 65535 
3. Sub axis rate : 1 ~ 65535 

XSSS 

Position sync. 

1. Step : 1 ~ 400 
2. Position (each Unit range) 

pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 

inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 
3. Main axis range : Axis 1 ~ Axis 4 and Encoder 

XSSP 

Speed sync. 
with position 

1. Main axis range : Axis 1~  Axis 4 and Encoder  
2. Main axis rate : 1 ~ 65535 
3. Sub axis rate : 1 ~ 65535 
4. Position (each Unit range) 

pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 

inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 

 

CAM operation 1. Main axis range : Axis 1 ~ Axis 4 
2. CAM block : No.1 ~ No.8 

XCAM 

Ellipse 
interpolation 

1. Step: 1 ~ 400  
2. Range: 0 ~ 65535 [X10-2 %]  
3. Each operation: 0 ~ 65535 [X10-1 degree 

XELIN 

Synch start  Axis : Select 1 ~ 4 axis, Step No.: 1 ~ 400 XSST  
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③ Network type XPM (XGF-PN8A), standard network type XPM (XGF-PN8B) 

Screen Command Setting range Related 
command

 

Speed sync. 
1. Main axis range : Axis 1 ~  Axis 8 and Encoder 
2. Main axis rate : 1 ~ 65535 
3. Sub axis rate : 1 ~ 65535 

XSSS 

Position sync. 

1. Step : 1 ~ 400 
2. Position (each Unit range) 

pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 

inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 
3. Main axis range : Axis 1 ~ Axis 8 and Encoder 

XSSP 

Speed sync. 
with position 

1. Main axis range : Axis 1~  Axis 8 and Encoder  
2. Main axis rate : 1 ~ 65535 
3. Sub axis rate : 1 ~ 65535 
4. Position (each Unit range) 

pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 

inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 

 

CAM operation 1. Main axis range : Axis 1 ~ Axis 8 
2. CAM block : No.1 ~ No.8 

XCAM 

Ellipse 
interpolation 

1. Step: 1 ~ 400  
2. Range: 0 ~ 65535 [X10-2 %]  
3. Each operation: 0 ~ 65535 [X10-1 degree 

XELIN 

Synch start  Axis : Select 1 ~ 4 axis, Step No.: 1 ~ 400 XSST  
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(3) Modification command 

         ① APM module (XGF-POxA, XGF-PDxA) 

Screen Command Setting range Related 
command

 

Position 
override 

Position (Each Unit range) 
pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 

inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 

POR 

Speed 
Override 

Speed (Each Unit range) 
pulse  : 0 ~ 1,000,000 [pulse/sec](XGF-PDxA) 
pulse  : 0 ~ 200,000 [pulse/sec](XGF-POxA) 
mm : 0 ~ 2,000,000,000 [X10-2 mm/min](XGF-POxA, XGF-PDxA) 
inch : 0 ~ 2,000,000,000 [X10-3 inch/min](XGF-POxA, XGF-PDxA) 
degree : 0 ~ 2,000,000,000 [X10-3 degree/min] 
(XGF-POxA, XGF-PDxA) 

SOR 

Pos.-
specified 
Speed 

Override 

1. Position (Each Unit range) 
pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 

inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 
2. Speed (Each unit range) 

pulse  : 0 ~ 1,000,000 [pulse/sec](XGF-PDxA) 
pulse  : 0 ~ 200,000 [pulse/sec](XGF-POxA) 
mm : 0 ~ 2,000,000,000 [X10-2 mm/min](XGF-POxA, XGF-PDxA) 
inch : 0 ~ 2,000,000,000 [X10-3 inch/min] 
(XGF-POxA,XGF-PDxA) 
degree : 0 ~ 2,000,000,000 [X10-3 degree/min] 
(XGF-POxA, XGF-PDxA) 

PSO 

Current 
position 
preset 

1. Position (Each Unit range) 
pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 

inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 

PRS 

Encoder 
Preset 

Position : 0 ~ 4,294,967,295 [pulse] EPRS 

Start step  Step : 1 ~ 400 SNS 

Repeat step Step : 1 ~ 400 SRS 

 
Pos. 

Repeat. 

Position (Each unit range) 
pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 

inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 

RCP 
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        ② XPM module (XGF-POxH, XGF-PDxH) 

Screen Command Setting range Related 
command

 

Position 
override 

Position (Each Unit range) 
pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 

inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 

XPOR 

Speed 
Override 

Speed (In case of designating %) 
0 ~ 65535 [X10-2 %]  
Speed (in case of designating speed, each unit range) 
pulse  : 0 ~ 4,000,000 [pulse/sec](XGF-PDxH) 
pulse  : 0 ~ 500,000 [pulse/sec](XGF-POxH) 
mm : 0 ~ 2,000,000,000 [X10-2 mm/min](XGF-POxH, XGF-PDxH) 
inch : 0 ~ 2,000,000,000 [X10-3 inch/min](XGF-POxH, XGF-PDxH) 
degree : 0 ~ 2,000,000,000 [X10-3 degree/min] 
(XGF-POxH, XGF-PDxH) 
(Decided designating % or designating speed at [Speed Override] 

parameter setting of common parameter.) 

XSOR 

Pos-
specified 
Speed 

Override 

1. Position (Each Unit range) 
pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 

inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 
2. Speed(In case of designating %) 

0 ~ 65535 [X10-2 %]  
Speed (In case of designating speed, each unit range) 
pulse  : 0 ~ 4,000,000 [pulse/sec](XGF-PDxH) 
pulse  : 0 ~ 500,000 [pulse/sec](XGF-POxH) 
mm : 0 ~ 2,000,000,000 [X10-2 mm/min](XGF-POxH, XGF-PDxH) 
inch : 0 ~ 2,000,000,000 [X10-3 inch/min](XGF-POxH, XGF-PDxH) 
degree : 0 ~ 2,000,000,000 [X10-3 degree/min] 
(XGF-POxH, XGF-PDxH) 

    (Decided designating % or designating speed at [Speed Override] 
parameter setting of common parameter.) 

XPSO 

Current 
position 
preset 

1. Position (Each Unit range) 
pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 

inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 

XPRS 

Encoder 
Preset 

1. Position : -2,147,483,648 ~ 2,147,483,647 [pulse]  XEPRS

Start step  Step : 1 ~ 400 XSNS 

Repeat step Step : 1 ~ 400 XSRS 
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③ Network type XPM (XGF-PN8A), standard network type XPM (XGF-PN8B) 

Screen Command Setting range Related 
command

 

Position/ 
Torque 

switching 

Torque value: -300~300% 
(Sets the ratio to the rated torque of the servo parameter)  

XPTT 

Position 
override 

Position (Each Unit range) 
pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 
inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 

XPOR 

Speed 
Override 

Speed (In case of designating %) 
0 ~ 65535 [X10-2 %]  
Speed (in case of designating speed, each unit range) 
pulse  : 0 ~ 10,000,000 [pulse/sec] 
mm : 0 ~ 2,000,000,000 [X10-2 mm/min] 
inch : 0 ~ 2,000,000,000 [X10-3 inch/min]  
degree : 0 ~ 2,000,000,000 [X10-3 degree/min] 
(Decided designating % or designating speed at [Speed Override] 
parameter setting of common parameter.) 

XSOR 

Pos-
specified 
Speed 

Override 

1. Position (Each Unit range) 
pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 

inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 
2. Speed(In case of designating %) 

0 ~ 65535 [X10-2 %]  
Speed (In case of designating speed, each unit range) 
pulse  : 0 ~ 10,000,000 [pulse/sec] 
mm : 0 ~ 2,000,000,000 [X10-2 mm/min] 
inch : 0 ~ 2,000,000,000 [X10-3 inch/min] 
degree : 0 ~ 2,000,000,000 [X10-3 degree/min] 

   (Decided designating % or designating speed at [Speed Override]
parameter setting of common parameter.) 

XPSO 

Current 
position 
preset 

1. Position (Each Unit range) 
pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 

inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 

XPRS 

Encoder 
Preset 

1. Position : -2,147,483,648 ~ 2,147,483,647 [pulse]  XEPRS

Start step  Step : 1 ~ 400 XSNS 
Repeat step Step : 1 ~ 400 XSRS 

Current 
position 
section 
repeat 

Position (Each Unit range) 
pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 

inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 

XRCP 
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(4)  Teaching Command 
① APM module (XGF-POxA, XGF-PDxA) 

Screen Command Setting range Related 
command

Single 
teaching 

1. Step : 1 ~ 400 
2. System : 0 (RAM teaching), 1 (ROM teaching) 
3. Method : 0 (Position teaching), 1 (Speed teaching) 
4. The number : 1 ~ 16 

TEA 

Multiple 
teaching 

1. Step : 1 ~ 400 
2. System : 0 (RAM teaching), 1 (ROM teaching) 
3. Method : 0 (Position teaching), 1 (Speed teaching) 
4. The number : 1 ~ 16 

TEAA 

Teaching 
value 

Position  
pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 

inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 

JOG 
teaching 

1. Method : 0 (RAM teaching), 1 (ROM teaching) 
2. Data : 0 (JOG high speed), 1 (JOG low speed) 
3. Speed :  
pulse  : 0 ~ 1,000,000 [pulse/sec](XGF-PDxA) 
pulse  : 0 ~ 200,000 [pulse/sec](XGF-POxA) 
mm : 0 ~ 2,000,000,000 [X10-2 mm/min](XGF-POxA, XGF-PDxA)
inch : 0 ~ 2,000,000,000 [X10-3 inch/min]  
(XGF-POxA, XGF-PDxA) 
degree : 0 ~ 2,000,000,000 [X10-3 degree/min]  
(XGF-POxA, XGF-PDxA) 

TMP 

 
② XPM module (XGF-POxH, XGF-PDxH, XGF-PNxA), network type XPM (XGF-PN8A),  

standard network type XPM (XGF-PN8B) 

Screen Command Setting range Related 
command

Multiple 
teaching 

1. Step : 1 ~ 400 
2. System : 0 (RAM teaching), 1 (ROM teaching) 
3. Method : 0 (Position teaching), 1 (Speed teaching) 
4. The number : 1 ~ 16 

XTEAA 

Teaching 
value 

Position  
pulse  : -2,147,483,648 ~ 2,147,483,647 [pulse] 
mm : -2,147,483,648 ~ 2,147,483,647 [X10-1 mm] 

inch : -2,147,483,648 ~ 2,147,483,647 [X10-5 inch] 

degree : -2,147,483,648 ~ 2,147,483,647 [X10-5 degree] 
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(5)  Point operation (APM, XPM, network type XPM, standard network type XPM common) 

Screen Command Setting range Related 
command

POINT 
Operation 

1. The number : 1 ~ 20 
2. Point setting (0 ~ 19) : 1 ~ 400  

=> Operation step setting 

PST(APM)
XPST(XPM)

 
(a)  Point operation operate maximum 20 set operation step positioning by once. 
(b)  When set the step number, have to set highest step No. while operating mode is continue or consecutive. 
(c)  When operate point operation, if set the number of point, below item(0~19) is revitalized as the set number. 

 
 
 

10.2.4  Jog Operation 
 
Operate to Jog command by clicking Jog operation icon. 

 

Screen Icon Command Related 
command

  Reverse high speed jog operation. 

- 

  Reverse low speed jog operation. 

  Forward low speed jog operation  

  Forward high speed jog operation 

  Jog operation stop 
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10.3  Command Icon 
 
Can easily process command, executed solely without command condition, through icon 

 
 [Composition of a picture] 

  

 
[Screen description] 
 
Command 

Icon Command contents Operation description Note 

 Axis stop Designated axis deceleration command Common

 Emergency stop Internal emergency stop command during operation. Common

 Homing Homing command. Common

 
Immoveable origin 

setting 
Origin setting command by software. Common

 
Speed/Position 

Conversion 
This command for converse to positioning control during speed control 
operation. 

Common

 
Position/Speed 

Conversion 
 This command for converse to speed control during speed control 
operation. 

Common

 Skip operation  Stop current operating step and operate next step. Common

 Consecutive operation  Operation pattern of current operation step change to consecutive 
operation, operate to next step without stop section. 

Common

 
Manual operation 

before homing 

 Operate manual operation (jog operation, inching operation) after 
complete positioning operation, then in case of positioning spot is 
changed, it is moved to positioning completion spot before manual 
operation. 

Common

 Cancel M Code  This command cancels M code.  Common

Enable ZONE Output  Enable ZONE output. Only APM

 Disable ZONE Output  Disable ZONE output Only APM

Enable MPG  Enable MPG  Only APM

Disable MPG  Disable MPG  Only APM

 Error history reset  Clear current error history during operation. Only APM

 Error reset  Clear current error during operation. Common
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10.4  Example of Test Run  
 
Here describes example of test run when test run needed. 
 

10.4.1  Jog Operation 
Following example describes jog operation for testing initialize operation after connect with motor.  
 
[APM module Sequence] 

1) Make a new project by proceeding [Project]->[New project]. 
2) Proceed [Online]->[connect] , online with module.  
3) Revitalize operation parameter screen of axis for performance.  
4) Set jog parameter of manual operation parameter on the operation parameter.  

(Set Jog high speed/Jog low speed/Jog acceleration time/Jog deceleration time) 
5) Proceed [Online]->[Write] , write the set jog parameter to module. 

(Please refer to this manual 9.1 writing data for method of writing.  
6) Select axis for performing jog operation at the command tool. 

(Please refer to 10.2.1. select of command axis.) 
7) Proceed jog operation with basic command tab of command tool window. 
8) Confirm jog operation by system view screen. 

 
[Confirm performance] 

Following example is system view screen after performing jog operation on the axis X, axis Y.  
(Perform automatically monitoring function when perform jog operation.) 

 
a) Command speed: When proceed jog low(high) speed operation, set value will be displayed by operation parameter. 
b) Operation status: Operation status is displayed as “Steady speed” while it is jog operating. 
c) Control pattern: Operation status is displayed as “Jog operating” while jog operating. 

 

a 

b 

c 
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[XPM module Sequence] 

1) Make a new project by proceeding [Project]->[New project]. 
2) Proceed [Online]->[connect] , online with module.  
3) Revitalize operation parameter screen of axis for performance.  
4) Set jog parameter of manual operation parameter on the operation parameter.  

(Set Jog high speed/Jog low speed/Jog acceleration time/Jog deceleration time) 
5) Proceed [Online]->[Write] , write the set jog parameter to module. 

(Please refer to this manual 9.1 writing data for method of writing.  
6) Select axis for performing jog operation at the command tool. 

(Please refer to 10.2.1. select of command axis.) 
7) Proceed jog operation with basic command tab of command tool window. 
8) Confirm jog operation by system view screen. 

 
[Confirm performance] 

Following example is system view screen after performing jog operation on the axis 1, axis 2.  
(Perform automatically monitoring function when perform jog operation.) 

 

a) Command speed: When proceed jog low(high) speed operation, set value will be displayed by operation parameter. 
b) Operation status: Operation status is displayed as “Steady speed” while it is jog operating. 
c) Control pattern: Operation status is displayed as “Jog operating” while jog operating. 

a 

b 
c 
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[Network type XPM, standard network type XPM Sequence] 

1) Make a new project by proceeding [Project]->[New project]. 
2) Proceed [Online]->[connect] , online with module.  
3) Proceed [Online]->[Connect to all servo] to connect the module to servo.  
4) Make the axis for JOG operation “Servo on” status  
5) Revitalize operation parameter screen of axis for performance.  
6) Set jog parameter of manual operation parameter on the operation parameter.  

(Set Jog high speed/Jog low speed/Jog acceleration time/Jog deceleration time) 
7) Proceed [Online]->[Write] , write the set jog parameter to module. 

(Please refer to this manual 9.1 writing data for method of writing.  
8) Select axis for performing jog operation at the command tool. 

(Please refer to 10.2.1. select of command axis.) 
9) Proceed jog operation with basic command tab of command tool window. 
10) Confirm jog operation by system view screen. 

 
[Confirm performance] 

Following example is system view screen after performing jog operation on the axis 1, axis 2.  
(Perform automatically monitoring function when perform jog operation.) 
 

    

 

a) Command speed: When proceed jog low(high) speed operation, set value will be displayed by operation parameter. 
b) Operation status: Operation status is displayed as “Steady speed” while it is jog operating. 
c) Control pattern: Operation status is displayed as “Jog operating” while jog operating. 

a 

b 

c 
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10.4.2  Direct Start (single axis position control) 
Here describes Shortcut position control by direct start. 

 
[Sequence] 

1) Create new project by proceeding [Project]->[New project]. 
2) Online module by proceeding [Online]->[Connect].  
3) Execute stability origin setting command for directing start operation.(shortcut icon ). 
4) Revitalize basic command tab of command tool window. 
5) Execute direct start by operation condition. 

 
[Setting screen] 

 
[Setting value] 

 

Setting item Setting value Content 

Position 100,000 pls  Operate motor to 100,000 pls. 
Speed 10,000 pls/s  Operate motor as 10,000 pls/s. 

Dwell 100 ms  Dwell time is 100ms after operating. 

M code 10  M code is 10 while it is operating.ex1)

Acceleration No.1 Operate No.1 during accelerating. 

Deceleration No.1 Operate No.1 during accelerating.  

Coordinate Absolute  Operate absolute position coordinate. 

Method Position control  Operation method operates by position control method. 
ex1)  M code mode(Operation parameter->Expansion parameter) should be set as 1 : With(Display M code during 
operating) or 2 : After(Display M code after operating) for displaying M code on screen. 

Confirm M code after operation complete by set 2. 
 

 
 
 
 

Setting item 
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[APM module operation] 

This is a screen of system view after operation complete when it is operating by data setting. 

                  
[XPM operation] 

This is a screen of system view after operation complete when it is operating by data setting. 

                  
a) Current position: Current position display target position value 100,000. 
b) M code No.: Display setting value 10. 
c) M code On : Current M code display 10, display M code on the screen.  

a 

b 

c 

a 

b 

c 
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[Network type XPM, standard network type XPM operation] 

This is a screen of system view after operation complete when it is operating by data setting. 
 
 

 

 

 

a) Current position: Current position display target position value 100,000. 
b) M code No.: Display setting value 10. 
c) M code On : Current M code display 10, display M code on the screen.  

 
 

Notes  
 
Cancel M code On: In case of displaying M code, Have to cancel M code for operating other command when it is restart after 
operation complete. 
M code can be cancelled by [Cancel M code] on the command tool bar. (shortcut Icon  )  

 
 

a 

b 

c 
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10.4.3  Indirect Start (single axis position control and circular interpolation) 
Following example describes about operation method by indirect start (operation data).  

 
(1) Single-axis position control 

 
[Sequence] 

1) Create new project by proceeding [Project]->[New project]. 
2) Online module by proceeding [Online]->[Connection].  
3) Connect the module to the servo drive by proceeding [Online] -> [Connect to all servo] (network type) 
4) Make the axis “Servo on” status at the servo tool (network type) 
5) Operate stability origin setting command on the axis for direct start. (Shortcut Icon ). 
6) Set data after revitalize operation data screen of axis for start. (Proceed simply view after revitalize) 
7) Write operation data to module by proceeding [Online]->[Write]. 

(Refer to this manual 9.1 writing data for execution method)  
8) Revitalize basic command tab of command tool window. 
9) Set step No. of indirection start item and click the start button. 

  
[APM module Setting screen] 

 
  

                    
 

Setting item 

Setting item 



 

 

 

 

 

Chapter 10 Test run by XG-PM 

 

 

    

10-25

 
[XPM, network type XPM, standard network type XPM Setting screen] 

 
 
 
 

 
[Setting value] 

Setting item Setting value Contents 
Control method Absolute, Single-axis position control  Execute position control operation by absolute coordinate. 

Operation method Single, End  Execute single stop operation of current step. 

Target position 1,000,000 pls  Operate motor to 1,000,000 pls. 

Operation speed 100,000 pls/s  Operate motor as 100,000 pls/s. 

Acceleration No. No.1  Set acceleration speed as No.1. 

Deceleration No. No.1 Set deceleration speed as No.1. 

M code 10  M code is 10, when it is operating.  

Dwell time 0 ms Dwell time is 0ms after operation. 

 
[APM operation] 

This picture is the system view screen of operation complete by data setting. 
(It is same with result of 10.4.2 direct start (single axis position control). 

Setting item 

Setting item 
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[XPM operation] 
This picture is the system view screen of operation complete by data setting. 
(It is same with result of 10.4.2 direct start (single axis position control). 

                 
 

a 
b 

c 

d 

a 
b 

c 

d 
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[Network type XPM, standard network type XPM operation] 

This picture is the system view screen of operation complete by data setting. 
(It is same with result of 10.4.2 direct start (single axis position control). 
 

  
 
a) Current position: Current position display target value 100,000. 
b) Step No.: Display 2 as next step of indirect step. 
c) M code No.: Display setting value 10. 
d) M code ON: Display current M code 10 and Display M code on current screen.  
 

 
Notes  
 
Can change operation data displaying item for convenient by menu on display part of each axes, when set operation data. 
 (View detail / Simply detail function, refer to manual 8.3.1) 

 
 
 

 
 

 

a 

b 

c 

d 
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(2) Circular Interpolation  
 
[APM module Sequence] 

1) Create new project by proceeding [Project]->[New project]. 
2) Online module by proceeding [Online]->[Connect].  
3) Execute stability origin setting command on the axes (axis X, axis Y) for circular interpolation.(Shortcut Icon ). 
4) Revitalize operation data screen of axis which need to start and set data. (Execute detailed view after revitalize) 
5) Write operation data to module by proceeding [Online]->[Write]. 

(Refer to this manual 9.1 writing data for execution)  
6) Revitalize basic command tab of command tool window. 
7) Revitalize XY graph after proceeding [Monitoring]->[Trend Monitoring]  . 
8) Set current position (axis X: axis X current position, axis Y: axis Y current position) after proceeding [Graph]->[Trend device 

setting]. 
(Refer to this manual 11.6 data trend for setting.) 

9) Click start button after setting step number as 1 and slave as Axis Y in the circular interpolation item of command tool.  
(Then command axis should be set axis X. Axis X is main executing axis on the below example.) 

  
[Setting screen] 
 
 
 

 
 
 
 

 
 
 
 

 

Axis X data setting 

Axis Y data setting 

Center point setting 
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[Setting value] 
 [Axis X data] 

Setting item 
Setting value 

Content 
Step 1 

Coordinate Absolute  Execute operation by absolute coordinate. 

Control type Position  Execute operation by position control 

Operation pattern End  Set operation pattern as END 

Operation type Single  Set operation type as single 

Target position[pls] 0 pls  Both start and end point is 0 pls. 

Circular interpolation 
auxiliary point 

500,000 
 Set circular interpolation auxiliary point (Center point ) as 
500,000 

M code 10  Display M code 10 while operating.  

ACC/DEC No. No.1  Set ACC/DEC number as No.1. 

Speed 100,000  Operate motor with 100000 pls/s speed 

Dwell time[ms] 0 ms Dwell time is 0ms after operating. 

Circular interpolation 
direction 

CW Set circular interpolation as CW (Clockwise) 

 
 

[Axis Y data] 

Setting item 
Setting value 

Content 
Step 1 

Coordinate Absolute  Execute operation by absolute coordinate. 

Control type Position  Execute operation by position control 

Operation pattern End  Set operation pattern as END 

Operation type Single  Set operation type as single 

Target position[pls] 0 pls  Both start and end point is 0 pls. 

Circular interpolation 
auxiliary point 

500,000 
 Set circular interpolation auxiliary point (Center point ) as 
500,000 

M code 10  Display M code 10 while operating.  

ACC/DEC No. No.1  Set ACC/DEC number as No.1. 

Speed 100,000  Operate motor with 100000 pls/s speed 

Dwell time[ms] 0 ms Dwell time is 0ms after operating. 

Circular interpolation 
direction 

CW Set circular interpolation as CW (Clockwise) 
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[Confirm operation]  
This is XY graph on the trend screen after operation complete by data setting.  
This is an example for drawing circle that center point is (500000, 500000). 
(Axis X is current position of axis X, axis Y is current position of axis Y.) 

 
 

[XPM, network type XPM, standard network type XPM Sequence] 
1) Create new project by proceeding [Project]->[New project]. 
2) Online module by proceeding [Online]->[Connect].  
3) Connect the module to the servo drive by proceeding [Online] -> [Connect to all servo] (network type) 
4) Make the axis for indirect start “Servo on” status at the servo tool (1 and 2 axis servo on, network type) 
5) Execute stability origin setting command on the axes(axis1, axis2) for circular interpolation.(Shortcut Icon ). 
6) Revitalize operation data screen of axis which need to start and set data. (Execute detailed view after revitalize) 
7) Write operation data to module by proceeding [Online]->[Write]. 

(Refer to this manual 9.1 writing data for execution)  
8) Revitalize basic command tab of command tool window. 
9) Revitalize XY graph after proceeding [Monitoring]->[Trend Monitoring]  . 
10) Set current position (axis X: 1, axis Y: 2) after proceeding [Graph]->[Trend device setting]. 

(Refer to this manual 11.6 data trend for setting.) 
11) Click start button after setting step No. of indirect start item as 1.  

(Then command axis should be set axis1. Axis1 is main executing axis on the below example.) 
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[Setting screen] 
 
 

 
 
 

 
[Setting value] 
 [Axis 1 data] 

Setting item 
Setting value 

Content 
Step 1 Step 2 

Control type Absolute, 
circular interpolation 

Absolute,  
circular interpolation  Execute circular interpolation operation by absolute coordinate.

Operation type Single, keep Single, End  Execute 2 step to succeed 1 step.  

Target position[pls] 1,000,000 pls 0 pls  Operate motor to 1,000,000 -> 0 pls 

Operation speed[pls/s] 100,000 pls/s 100,000 pls/s  Operate motor as 100,000 pls/s. 

Accel No. No.1 No.1  Set acceleration speed as No.1. 

Decel No. No.1 No.1  Set deceleration speed as No.1. 

M code 10 20  Display M code as 10, 20 while operating.  

Dwell time[ms] 0 ms 0 ms Dwell time is 0ms after operating. 

Sub axis setting Axis 2 Axis 2 Sub axis is axis1, sub axis is axis2, when it is setting. 

Cir. int. auxiliary point 500,000 500,000 Auxiliary point(center point) is (500,000, 0). 

Cir. int. mode Center point, CW Center point, CW Operate to CW by center point method. 

 
[Axis 2 data] 

Setting item 
Setting value 

Content 
Step 1 Step 2 

Control type Absolute,  
Circular interpolation 

Absolute,  
Circular interpolation  Execute circular interpolation operation as absolute coordinate. 

Operation type Single, Kee[ Single, End  Execute 2 step to succeed 1 step.  

Target position[pls] 0 pls 0 pls Starting point and end point are both 0 pls. 

Operation 100,000 pls/s 100,000 pls/s  Operate motor as 100,000 pls/s. 

Accel No. No.1 No.1  Set acceleration speed as No.1. 

Decel No. No.1 No.1  Set deceleration speed as No.1. 

M code 10 20  Display M code as 10, 20 while operating.  

Dwell time[ms] 0 ms 0 ms Dwell time is 0ms after operating. 

Sub axis setting Axis unset Axis unset Main axis is axis1, sub axis is axis2, when it is setting. 

Cir. int. auxiliary 
point 0 0 Auxiliary point(center point) is (500,000, 0). 

Cir. int. mode Center point, CW Center point, CW Operate to CW by center point method. 

Axis 1 data setting 

Axis 2 data setting 
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[Confirm operation]  
This is XY graph on the trend screen after operation complete by data setting.  
This is an example for drawing circle that center point is (500000, 0), Radius is 1000000. 
(Axis X is current position of axis1, axis Y is current position of axis2.) 
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10.4.4  Speed Synch 
Speed synch means that sub axis operate speed synch as set rate, even if main axis speed is variable by operation speed rate of 
sub/main axis. Following example shows example of speed synch operation.  

 
[APM module Sequence] 

1) Create new project by proceeding [Project]->[New project]. 
2) Online module by proceeding [Online]->[Connection].  
3) Execute stability origin setting command on the axis for speed synch operation(axis X and axis Y).(Shortcut Icon ). 
4) Write operation parameter to module by proceeding [Online]->[Write]. 

(Refer to 9.1. writing data for writing execution method.)  
5) Click the speed synch execution button after setting speed synch item on the expansion command tab of command tool 

window.  (Refer to setting data.) 
6) Set the direct start item on the basic command tab of command tool window. (refer to setting data) 
7) Revitalize trend graph tab after operating data trace program by proceeding [Monitor]->[Trend Monitor]. 
8)  After executing [Trend device setting], set axis X current position and axis Y current position as device at the Trend graph 

tap. 
9)  Set command axis as axis1 and execute direct start. 
10) Confirm operating by system view and data trace. 

 
[Setting screen] 
 
 
 

  
 
 
 
 
 

  
 
 
 
 
 

Data setting 
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[Setting value] 
 
    [Operation parameter setting]  

Setting item 
Setting value 

Content 
Axis X Axis Y 

ACC/DEC time1 500 ms 500 ms 
Axis X, Y ACC/DEC time setting 
 (Each axis operation parameter  

=> Set on the basic parameter) 
 
    [Speed synch item setting] 

Setting item Detail item Setting value Content 

Speed synch 
Main axis X  Set axis X as main axis. 

Main axis rate 2  Set 2 as main axis speed rate. 
Sub axis rate 1 Sub axis speed rate set 1/2 to main axis. 

 
    [Speed synch item setting] 

Item Detail item Setting value Content 

Direct start 
Command axis X 

 Set axis X as command axis. 
 (refer to this manual 10.2.1) 

Position 1,000,000 pls  Set target position. 
Speed 10,000 pls/s Set starting speed. 

 

Data setting 
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[Confirm Operation] 
    [System view] 

  
a) Position: Speed of Axis X is twice that of axis Y. So position of axis X is twice that of axis Y. 
b) Axis Y is under speed synch. operation. 

 
    

b 

a 
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 [Trend monitor] 

 
This is a trend graph after operating by upper data setting.  
 (Speed synch main axis: Sub axis speed = 2 : 1)   
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[XPM, network type XPM, standard network type XPM Sequence] 
1) Create new project by proceeding [Project]->[New project]. 
2) Online module by proceeding [Online]->[Connection].  
3) Connect the module to the servo drive by proceeding [Online] -> [Connect to all servo] (network type) 
4) Make the axis for indirect start “Servo on” status at the servo tool (1 and 2 axis servo on, network type) 
5) Execute stability origin setting command on the axis for speed synch operation(axis1 and axis2).(Shortcut Icon ). 
6) Write operation parameter to module by proceeding [Online]->[Write]. 

(Refer to 9.1. writing data for writing execution method.)  
7) Click the speed synch execution button after setting speed synch item on the expansion command tab of command tool 

window.  (Refer to setting data.) 
8) Set the indirect start item on the basic command tab of command tool window. (refer to setting data) 
9) Revitalize trend graph tab after operating data trace program by proceeding [Monitor]->[Data trace]. 

Set axis 1 command speed, axis 2 command speed on the word device setting tab after proceeding [Trace]->[Trace 
setting] of date trace program. (Refer to this manual 11.7 data trace for setting.) 

10) Set command axis as axis1 and execute direct start. 
11) Confirm operating by system view and data trace. 

 
[Setting screen] 
 
 
 

  
 

 
 
 

 
 

Data setting 

Data setting 
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[Setting value] 
 
    [Operation parameter setting]  

Setting item 
Setting value 

Content 
Axis 1 Axis 2 

Acceleration time 1 10000 ms 10000 ms 
Axis1,2 deceleration time setting 
 (Each axis operation parameter  

=> Set on the basic parameter) 

Deceleration time 1 10000 ms 10000 ms 
Axis1,2 deceleration time setting 
 (Each axis operation parameter  

=> Set on the basic parameter) 
 
    [Speed synch item setting] 

Setting item Detail item Setting value Content 

Speed synch 
Main axis 1  Set axis1 as main axis. 

Main axis rate 1  Set 1 as main axis speed rate. 
Sub axis rate 2 Sub axis speed rate set a multiple to main axis. 

 
    [Speed synch item setting] 

Item Detail item Setting value Content 

Direct start 
Command axis 1 

 Set axis 1 as command axis. 
 (refer to this manual 10.2.1) 

Position 50,000 pls  Set starting position. 
Speed 10,000 pls/s Set starting speed. 
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[Confirm Operation] 
    [XPM System view] 

 
 
[Network type XPM, standard network type XPM System view] 

  
a) Command speed: Axis 2 speeds increase to 2 times of axis 1 speed with operating. 
b) Control pattern: In case of axis1, display as axis1 position control operation, axis2 operation control is displayed as speed 

synch. 

b 

a 

b 

a 
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 [Data trace] 
 
This is a trend graph after operating by upper data setting.  
Can confirm that the steady speed section speed of axis1 is 10,000 pls/s, the steady speed section speed of axis2 is 
20,000 pls/s. (Speed synch main axis: Sub axis speed = 1 : 2)   
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Chapter 11 Useful Function of XG-PM 
 
XG-PM provides many useful functions for making project, editing project. XG-PM providing functions are as follows: Plural module 
batch write/read/comparison for each project, copy data for each unit, synchronize I/O, data trend, data trace and electronic CAM 
operation.  
 
 

11.1  Project Management Function 

11.1.1  Project Initialization Function 
 

  XG-PM provides project initialization function for convenient. 
 
[APM, XPM module Sequence] 

1)  Proceed [Project]->[Project Initialization wizard]. 
2)  Project setting communication box is displayed on the screen when click the connection button at connection setting 

communication box.  

 
 

3)  Set the project information on the project setting communication box and click the next button. At this time, select “Pulse 
output type” as the module type. 
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4)  Click the next button after confirming set project information at the project setting confirmation step.  

 
 

5)  Click the select/all button module for synchronization on module I/O synchronization. 
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6)  Click the next button after confirm synchronized module information on module I/O confirmation step. 

 
 
 

7)  Click the end button for end of project initializing.  
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[Network type XPM Sequence] 

1)  Proceed [Project]->[Project Initialization wizard]. 
2)  Project setting communication box is displayed on the screen when you click the connection button at connection setting 

communication box.  
3)  Set the project information on the project setting communication box and click the next button. At this time, select “network 

type” as the module type. 

 
 

4)  Click the next button after confirming set project information at the project setting confirmation step.  
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5)  Click the select/whole button module for synchronization module I/O synchronization. 
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6)  Click the next button after confirm synchronized module information on module I/O confirmation step. 

 
 

7)  Check the servo drive connection status and click “Next” button.  
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8)  Check the number of the axis and the axis information and press “Next” button. 
 

 

 

9)  Click the end button for end of project initializing. 
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[Standard network type XPM Sequence] 
1)  Proceed [Project]->[Project Initialization wizard]. 
2)  Project setting communication box is displayed on the screen when you click the connection button at connection setting 

communication box.  
3)  Set the project information on the project setting communication box and click the next button. At this time, select “Standard 

network type” as the module type. 

 
 

4)  Click the next button after confirming set project information at the project setting confirmation step.  
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5)  Click the Select or All button module for synchronization module I/O synchronization. 
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6)  Click the next button after confirm synchronized module information on module I/O confirmation step. 

 
 

7)  Check the servo drive connection status and click “Next” button.  
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10)  Check the number of the axis and the axis information and press “Next” button. 
 

 

 

11)  Click the end button for end of project initializing. 
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Tip  
 
After “Project initialization wizard”, new project is created. 
The function of Project initialization wizard is same as the result that you execute the following functions among XG-PM software 
package. 
 
1. Create new project 
2. Connect to all servo (Network type module) 
3. Read servo parameter (Network type module) 
4. Apply the “pulse count per one rotation – basic parameter” among operating parameter to servo parameter (network type 

module) 
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11.1.2 Multi-Module Batch Write/Read/Comparison 
 

XG-PM provides project management function for multi-module. Basically it provides some functions for write/read/comparison. 
(Don’t need to additional setting, can use menu that are write/read/comparison.) 
 

(1)  Write multi-module 
 

[Sequence] 
1) Proceed [Online]->[Write]. 
2) Select item for writing at project write communication box. If the Multi-module is onlined, can writing data to selected 

module. 
3) Click the confirm button after select item. 

 
[Communication box] 
 

               
[Communication box content] 

a) Check for each project: Can write all data of all onlined module for each project by checking. 
b) Check for each module: Can write all data item belonged to module. 
c) Check for each item: Can write data for each item. 
d) Confirm: End communication box. Begin to writing data after end of communication box. 
e) Cancel: End communication box. 

 
Notes  

 
Online modules which were set on the project write/read/comparison communication box of current step are displayed only. 
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(2)  Read multi module 

 
[Sequence] 

1) Proceed [Online]->[Read]. 
2) Select item for reading on the project reading communication box. If multi-module was onlined, user can read data to 

selected module. 
3) Select item and confirm. 

 
[Communication box] 
 

 
 
[Communication box description] 

a) Check for each project: Can read all data item of all onlined module for each project by chenking this part. 
b) Check for each Module: Read all data item belonged to module. 
c) Check for item: Can read data for each item. 
d) OK: End the communication box. Begine to read data after ending communication box. 
e) Cancel: End communication box. 

 
(3)  Multi-module comparison 

 
[Sequence] 

1) Proceed [Online]->[compare with module]. 
2) Select item for on the module and data comparison communication box. Select item for comparison on the module 

and data comparison communication box. If the multi-module is onlined, can compare data with selected module by 
user. 
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[Communication box] 

 
 
 
 
[Communication box description] 

a) Check for each project: If check this item, can compare all data item of all onlined module for each project. 
b) Check for each module: Can compare all data item which is belonged to module. 
c) Check for each item: Can compare data for each item. 
d) OK: End communication box. Begin to read data after end of communication box. 
e) Cancel: End communication box. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

c 

b 
a 

d e
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11.2  Editing Data Function 
 
XG-PM provides useful function for editing each data contents.  
It provides basic editing function which are data copy/Paste, even if provides initializing function for each item. And it provides editing 
data function that the function proceeds without other calculating by auto-fill function and auto-unit changes function. 
 

11.2.1  Copy/Paste 
 

When user edit Common parameter/Operation parameter/operation data, partially can proceed copy/Paste. 
 

(1)  Copy  
 
Copy selected range to clip board. 
 

[Sequence] 
1. Select copy for range.  
2. Click [Edit] --> [Copy]. 

 
  [Editorial screen] 
  [APM] 

 

[XPM, network type module] 

 
 

(2)  Paste 
 
Paste copied content to selected range. 

 
[Sequence] 

1. Select range for Pasting copied range. 
2. Click [Edit]->[Paste]. 
3. Data is displayed on the selected range. 
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[Editorial screen] 

      [APM module] 

 
 

 
 
[XPM, network type XPM, standard type XPM] 
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11.2.2  Set Value of Initial Data 
 

When user edit Common parameter/Operation parameter/operation data, partially can set initial value. 
 

[Sequence] 
1) Select range for setting initial value. 
2) Click [Edit]->[Initial value setting]. 
3) Selected data is set as initial value. 

 
[Editorial screen] 
[APM module] 

 
 

 
 
<XPM, network type XPM, standard type XPM> 

 
 

 
 
 
 

Notes  

Initial data value is displayed as black color, not initial data value is displayed as blue color. 
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11.2.3  Cancel/Restart Edition 
 

When user edits common parameter/operation parameter/operation data, it provides return/restore function. 
 

[Sequence] 
1) Edit data. 
2) Click [Edit]->[Cancel edit] or [Restart]. 

 
 

Notes  
 
 When Set CAM data, do not provides return/restore function. 
 

  

11.2.4 Auto fill 
 

When set operation data, user easily makes progressived data by auto fill function. But, auto fill function only can perform for 1 
vertical line.  
 

[SEquence] 
1) Set data on screen of the operation data. (Set data over 2.) 
2) Set data and move mouse pointer to right top of the last setting data. 
3) When mouse pointer change to“+”, then drag mouse. 
4) Automatically created data is filled in the selected cell. 

 
[Editorial screen] 
 
[APM module] 
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<XPM, network type XPM, standard network type XPM> 

 
 

11.2.5  Unit Auto Changing Function 
 

When edit operation parameter, if change each axis unit, unit and range of item about speed and position are automatically change. 
Following the example describes editorial screen, when unit of axis1 is change to [pulse]->[mm]. 
And user can edit data without additional operation because operation data of target position/operation speed item are 
automatically change by changing unit. 

 
[Operation parameter editorial screen] 
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[Operation data editorial screen] 
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11.3  Copy Data 
 
XG-PM provides useful data copy function when edit data item with XG-PM. Also provides not only copying each data item but copying 
each axis, copying module unit. 
 

11.3.1  Copy for Each Data Item 
 

[Sequence] 
1) Select item for copying data on the project tree. 
2) Proceed [Edit]->[Copy] after click mouse right button. 
3) Select item for pasting data on the project tree. 
4) Proceed [Edit]->[Paste] after click mouse right button. 

 
[Copy common parameter] 

 
 

 
Notes  

 
Perform copy for each item to CAM data/Common parameter/Operation data/Operation parameter. 
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11.3.2  Copy for Each Axis Data 
 

[Sequence] 
1) Select item on the project tree. 
2) Proceed [Edit]->[Copy] after click mouse right button. 
3) Select item on the project tree for Pasteing. 
4) Proceed [Edit]->[Paste] after click mouse right button. 

 
[Copy axis data] 

 
 

Notes  
 
When copy axis unit data, both Operation data/Operation parameter data is copied. 
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11.3.3  Copy Data for Each Module 
 

[Sequence] 
1) Select module item on the project tree. 
2) Proceed [Edit]->[Copy] after click mouse right button. 
3) Select module item from project tree for Paste. 
4) Proceed [Edit]->[Paste] after click mouse right button. 

 
[Copy module unit] 

 
 
 

Notes  
When copy module unit data, copy all CAM data/Common parameter and operation data from axis 1 to axis 4/Operation parameter 
item data. 
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11.4  Online Model Setting 
 
Online model setting function provides solution that it set onlined module on the current project and data which it is onlined on the 
module is made synchronize for fast and convenient method.   

 
[Sequence] 

1) Create project.  
2) Connect with PLC by [Online]->[Connect]. 
3) Proceed [Online]->[Online model setting]. 

 
[Communication box] 

 
[Communication box description] 

a. Project information: Display set module information on the current. 
b. System installation information: Display equipped positioning module information. 
c. All: Perform equipped entire positioning module for setting.  
d. Select: Selected positioning module make perform for setting on the project module. 
e. Synchronize data: Renew data by read data from equipped positioning module data.  
f. Close: End communication box. 
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11.4.1  Module Synch Function 
 
Module synchronize function recognize positioning module which it is exist on the PLC system and set that on the project. 
 

(1) Synch of Select Module 
 

[Sequence] 
1) Create project.  
2) Connect to PLC by [Online]->[Connect]. 
3) Proceed [Online]->[Online model setting]. 
4) Select module for synchronizing on online model setting communication box system equipment information window. 

 
[Communication box] 

 
 

5) Click the select button for module synchronize. 
 

[Communication box] 
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6) Set module name that it is need to synchronize and confirm. 

 
[Communication box] 

 
 

7) Confirm set module on the project. 
 

[Communication box] 

 
 
 

Notes  
 

 Module is automatically added to project tree when module is set on the project information after module synchronize. 
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(2) Synchronization of whole module 
 

[Sequence] 
1) Create project.  
2) Connect to PlC by proceeding [Online]->[connection]. 
3) Proceed menu [Online]->[online model setting]. 
4) Click Entire button for module synchronize. 

 
[Communication box] 

 
 
5) Set the module name for synchronize on module setting communication box and click. 

(Then module communication box is revitalized as much as the number of module, set the each module name 
for each module.) 

 
[Communication box] 
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6. Confirm set module on the project. 
 

[Communication box] 

 
 

 
 

Notes  
 This message will be displayed when click the “All” or “select” button after synchronizing entire module. 
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11.4.2  Data Synchro Function 
 

Provide setting function by read module data from PLC system. 
 

(1) Data synch of selecting module  
[Sequence] 

1. Create project.  
2. Connect to PLC by menu [Online]->[Connection]. 
3. Proceed menu [Online]->[Online model setting]. 
4. Select module for synchronize on the online model setting communication box system equipment information 

window. 
5. Check data synchronize item. 

[Communication box] 

 
6. Begin to read data from module when click the select button. 

 
[Communication box] 
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Notes  
 
When proceed module synchronize function, if check data synchronize item, then proceed module synchronize and data 
synchronize at the same time. 
 

 
 

(2) Data synch of whole module 
 

[Sequence] 
1. Create project.  
2. Connect to PLC by proceeding [Online]->[Connection]. 
3. Proceed [Online]->[Online model setting]. 
4. Check data synchronize item. 

 
[Communication box] 

 
 

5. Read data from module by click the selecting button. 
 

[Communication box] 
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11.5  Project Printing 
 
XG-PM provides project printing function for printing entire data which user set at once. These functions progressively print all contents 
of project. It performs setting item when it is selecting/printing, preview function, printing function. 
 

[Sequence] 
1) Proceed menu [Project]->[Project printing]. 
2) Project printing communication box is appeared. 
3) Set item what user need to print. 

 
[Communication box] 

 

 
 

[Communication box description] 
a) Project tree: Express tree structure which it can print on the project.  
b) Print button: Print checked item on the project tree. 
c) Save settings: Can save selected item at the project tree. 
d) Details: Set details selected item on the project tree. 
e) Preview: Provides preview function what it was checked on the project tree. 
f) Setting: Set entire printing. For example, set process printer setting, printing page setting, space setting, etc. 
 

 
Notes  

 
Detail button is revitalized only, when selected current item is [Cover]. 
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11.5.1  Printing setting 
 

Set paper and print. 
 
[Sequence] 

1) Click setting button on the project printing communication box or click mouse right button on the project tree. 
 
[Communicarion box] 

 
 

[Communication box description] 
a) Detail: To be revitalized when select cover setting item, detail setting is possible to [Cover]. 
b) Page setting: Can set paper setting for printing. 
c) Header/Footer: Can input header and footer. 
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11.5.2  Space Setting 
 

Set space for printing paper. 
 
[Sequence] 

1) Execute page setting menu after click the setting button on the project printing communication box or click mouse right 
button on the project tree. 

 
[Communication box] 

 
 

 
 
[Communication box description] 

a) Preview: Can preview layout of selected paper space. 
b) Paper: Select printing paper. 
c) Direction: Select printing direction of paper. 
d) Load Defaults: Change contents of space, header, footer as default when it is installed. 
e) Margin setting: Set space of printing paper. 
f) Printer: Can change printer setting. 

 
Notes  

 
1. When print contents should be careful that it is overlap with header/footer. 
2. Can not be printed without setting header/footer contents. 
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11.5.3  Header/Footer Setting 
 

Set contents of header/footer. 
[Sequence] 

1) Set header/footer with setting button on the project printing communication box or header/footer setting menu on the 
project tree. 

[Communication box] 

 
[Communication box description] 

a) Explain content: Input contents on the left/center/light of header/footer. 
b) Field interpolation button: Field is interpolated to current cursor position (editing box; left, center, right). 

 
 

Notes  

1. It is possible that it set header/footer by input of user and field. 
Ex) Input header/footer as“Today is the &d.” 

It will be printed as “Today is june 1, 2007.” 
 

2. Field contents  
(1) Date: Print as “&d-> yyyy-mm-dd”. 
(2) Time: Print as “&t -> hh:mm:ss”. 
(3) Project name: &p 
(4) Module name: &c 
(5) Module type: &T 
(6) Current page No./the number of entire page: &n -> Current No./The number of entire page of selected item. 
(7) File name: &f -> Current project file name. 
(8) File name that it is included route: &F -> It is displayed as directory route name that file name is included. 
(9) Project description: &C -> Print project description.  

a 

b 
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11.5.4  Cover Printing Setting 
 

It is possible that it set printing cover. 
 

[Sequence] 
1) Select cover on the project tree of printing communication box. 
2) Click the detail button or click enter key while select cover. 

 
[Communication box] 

              

 
[Communication box description] 

1) Cover paper: Basically A4 vertical direction. It depends on paper setting.  
2) Margin indication: Set margin is displayed by dotted line. 
3) Editorial box: That is preview. Content, Font, Position can be changed. 
4) Editorial button: Content of editorial box can be changed.  
5) Font button: It is possible that font of selected editorial box change. 
6) Addition: Can add new editorial box of cover page. 
7) Delete: Can delete selected editorial box. 

a 
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[Add contents sequence] 

1) Click the [Add] button. 
2) Mouse pointer move to paper.  
3) Mouse pointer change to next.  
4) Click the paper by mouse left button. 
5) Editorial communication box is appeared. 

 
6) In case of ending after edition, mouse cursor change to arrow. 
 

Notes  
 

1. Can line up editorial box in the paper and editorial box. 
- By mouse right button with menu. 

 

 
(1)  [Editorial box]-[Center]: Center selected editorial box. 
(2)  [String]-[Align left]: Contents is arraied to left side on the editorial box.  
(3)  No print frame of editorial box during printing. 
(4)  It is possible that move editorial box by arrow key. 
(5)  No provides cancel edition(Undo) and restart. 
(6)  Display real contents of field with preview, if the sentence includes field. When editing, display field. 
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11.6 Servo Tuning (Only Applied to Network Type XPM) 
 
You can connect to XGT servo series and check the connection status and alarm and execute the auto-JOG, auto-tuning easily 
through the XG-PM software package without the other software. 

 
[Sequence] 

1) Create a project  
2) Connect to PLC through menu [Online] -> [Connect] 
3) Connect to the servo drive connected to the module through menu [Online] -> [Connect to all servo] 
4) Select menu [Tool] -> [Servo Tuning] 

 
[Dialog box] 
 
 

 
 
 
 
[Dialog box description] 

a) Module information : select the module connected to the servo drive. 
b) Servo drive information : select a servo drive to execute servo-tuning among currently connected servo drives.  
c) EMG stop button : you can stop auto-Jog operation by this button when servo drive is under emergency status or 

malfunction during auto-Jog operation. 
d) Auto-tuning tap : screen providing auto-tuning function 
e) Manual-tuning tap : screen providing manual-tuning function 
f) JOG operation tap : screen providing JOG operation function  
g) Trace tap : screen monitoring data during operation. You can modify the parameter during operation and check the effect 

of the modified parameter with graph easily.  
h) Close : closes the dialog box. 
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11.6.1 Select Servo Drive for Tuning  
 

Select a servo drive for tuning  
 
[Sequence] 

a) Select the module connected to a servo for tuning at the “Module Information” list.  
b) Select a servo for tuning at the “Servo Axis Information” 

 
[Dialog box] 

 
 

Tip  

 
If you select the module information, servo drives connected to that module will refresh at the servo axis information list.  
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11.6.2 Auto-Tuning  
 

Auto-tuning is function that finds the inertia of system, by operating the control target system in accordance with specific pattern.  
 
[Sequence] 

a) Activate the auto-tuning tap 
 

[Setting screen] 

 
 
 
[Setting screen description] 

a) Operating mode selection : checks data according to operating mode and selects operating mode 
b) JOG speed setting: inputs JOG speed. Sets the auto JOG operation speed to find the inertia ratio of a servo. 
c) Auto tuning ON setting : activates the auto tuning function (ON button) or not (OFF button) 
d) Auto JOG operation start : starts auto tuning operation (Start button) or stops (Stop button)   
e) System response: increases or decreases system response by step 
f) PI-IP control ratio: increases or decreases PI-PH control ratio to find the PI-IP control ratio proper to the servo. 
g) System inertia ratio trace value: shows system inertia found by auto tuning   
h) Write: writes auto-tuning JOG operating mode and JOG speed data to the servo drive 
i) Refresh all: reads JOG speed, system response, PI-IP control ratio and system inertia ratio trace value from the servo 

drive 
 

 
Tip  
 
In case of an emergency, press “EMG stop” button on the top of dialog box. Then it executes “Auto JOG operation stop”.  
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11.6.3  Manual Tuning 
 

This function is used to tune more accurately with real load operation. Modify the value by pressing “INC” or “DEC” button. 
 
[Sequence 

1) Activate the manual tuning tap 
 

[Setting screen] 
 

 
 
 
 
 

[Setting screen description] 
a) Common : increases or decrease system response/inertia ratio/PI-IP control ratio 
b) Speed operation mode : increases or decreases proportional gain, time constant, ripple compensation, acceleration time 

and deceleration time used for speed operation mode.  
c) Position operation mode: increases or decreases feed-forward ratio, proportional gain used for position operation mode. 
d) Refresh: reads all values on the screen from the servo drive. 
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11.6.4  JOG operation 
 

You can check basic operation of the servo drive through JOG operation mode and check the JOG operation of 8 patterns through 
auto JOG operation.  
 
[Sequence] 

1) Activate JOG operation tap. 
 

[Setting screen] 
 

 
 
 
[Setting screen] 

a) JOG operation mode setting : sets the speed for JOG operation 
JOG On/JOG Off : turns on/off JOG operation 
<<button, >> button: If you press direction button after JOG On, the motor moves clockwise or counterclockwise with 
JOG speed 

b) Auto JOG operation mode setting: selects auto JOG operation mode 
Auto JOG Off: stops auto JOG operation 

c) Auto JOG setting: sets speed and time of 8 patterns used for auto JOG operation 
d) Refresh: reads all values on the screen from the servo drive  

 
 
 

a 
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11.6.5  Trace 
 

You can check command speed, current speed of a servo and load ratio with the graph   
 
[Sequence] 

1) Activate trace tap 
 

[Setting screen] 
 

 
 
 
 
[Setting screen] 

a) Select Graph 1 Item : selects the item for trace at graph 1. selects one among 15 items. 
b) Select Graph 2 Item : selects the item for trace at graph 2. selects one among 15 items. 
c) Select Graph 3 Item : selects the item for trace at graph 3. selects one among 15 items. 
d) Change item during tracing : you can trace while changing servo tuning parameter during tracing. You can check the 

position/speed of the servo changed by parameter change in real time through the graph.    
e) Trace start: starts trace 
f) Trace stop: stops trace 
g) Graph clear: clears all data on the graph  
h) Save graph: saves each graph as bit map type 
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11.7  Trend monitor 
 
Trend monitor read data from module with online and display graph. Trend monitor window compose by bit graph, trend graph, XY 
graph.  
Bit graph: Display On/Off of bit type device by step graph. 
Trend graph: Word type device value change to selected device type and display changing. Trend graph display changing value by 
device value change to changed data type.   
 

11.7.1  Begin to Trend Monitor 
[Sequence] 

1) Online module. 
2) Proceed menu [Monitoring]->[Trend monitoring]. 

 
[Trend monitoring window] 

 
 

[Trend monitor window description] 
a) Bit graph: Display bit device data. 
b) Bit graph index: Display bit device name and graph color. 
c) Display bit graph current step: Display step No. while it is operating axis of included set device. 
d) Bit graph current value: Display current value of bit device. 
e) Trend graph: Display data of word device. 
f) Trend graph index: Display trend graph name and graph color. 
g) Display trend graph current step: Display step No. while it is operating axis of included set device. 
h) Current value of trend graph: Display current value of trend device. 
i) XY graph: Display word device data by two-dimension graph. 
j) XY graph index: Display XY device name and graph color. 
k) XY graph current value: Current value of XY device display by two-dimension. 
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Notes  
 
The data which is displayed on the trend monitor can be different with real data. If you want to monitor correct timing, then use data 
trace function. 

 Refer to this manual 11.8 for data trace function. 
 

 

11.7.2  Trend Monitor Setting 
[Sequence] 

1) Proceed menu [Graph]-[Trend device setting]. 
 

[Communication box] 
 

 
[Communication box description] 

a) Max. samples to display: Display the number of scrollable maximum sample on the graph. 
b) Sample. time: Display maximum display sample for each monitoring cycle. 
c) Max. samples to keep: Display the number of maximum sample which it can save as file. 
d) Sample. time: Display maximum samples to keep for each monitoring cycle. 
e) Monitoring Frequency: Set cycle which it read data from module. If the cycle is more short, the data more correct, can 

give effect to efficiency of PLC scan and PC. 
f) Device setting: Set device for monitoring.  
g) OK: Apply changes and close the communication box. 
h) Cancel: Close the communication box. 
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Notes  

 
1. Maximum display sample can’t bigger than maximum sustain sample. 
2. Maximum display time can’t bigger than maximum sustain time. 
3. “Graph” is graph range which is displayed on the current screen, can horizontally scroll as much as the number of 

maximum display sample. 
4. Maximum sustain sample is the number of maximum sample which it can be saved. Refer to this manual 6.4.3 file for 

saving item as file. 
 

 
(1) Bit graph setting 

 
Input bit device for monitoring. 
 
[Sequence] 

1) Select bit graph tab on the trend device setting communication box. 
2) Input device of bit type.  

 
(2) Trend graph setting 

 
Input trend device for monitoring. 
 
[Sequence] 

1) Select trend graph tab on the trend device setting communication box. 
2) Input device of word type.  
 

Notes  
 

1. Can registrate total 8 devices with bit device and trend device. 
2. The setting of data type depends on device, set to BIT, WORD, DWORD type.  
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(3) XY graph setting 

 
Input XY device for monitoring. 
 
[Sequence] 

1) Select XY graph tab on the trend device setting communication box. 
2) Input axis X device and axis Y device.   

 
Notes  

 
1. Need to device setting for registration of axis X device and axis Y device on the XY graph. 
2. Axis X/Y device can select only one device which is set on the trend graph tab. 

 
 

11.7.3  Graph Setting 
[Sequence] 

1) Proceed menu [Graph]-[Graph setting]. 
 

[Communication box] 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

[Communication box description] 
a) Display Grid: Set displaying XY grid on the screen. 
b) Fix XY graph grid ratio: Set grid option of XY graph. (When check, horizontal/vertical grid rate should be same.) 
c) Display X Axis data: Set available display data and display method 
d) Min/Max value: Set min/max range of graph. 
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Notes  
 

1. Max/Min values only apply to axis Y of trend graph. But if current axis Y view is auto alignment,           
then can not be applied.  

2. Inputted minimum value is smaller than maximum value. 
3. Display min/max value range of real data and min/max value range of set graph is as following: 

The range of grey color is displayed by graph only. 
 
 

 
 
 
 
 
 
 
 

 
 

e) Bit graph legend position: Set index position of bit graph.  
f) Trend graph legend position: Set trend graph index position. 
g) XY graph legend: Set position of XY setting graph. 
h) Color setting: Set device color of each graph. 
i) OK: Close communication box after applying changing. 
j) Cancel: Close communication box. 

 
(1) Graph Color Setting Method 

 
[Sequence] 

1) Select device for changing color. 

 
2) Click color line. Communicator be display with clicking color line. Confirm after select color.  
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11.7.4  Setting Graph Window 
 

Setting display graph view changing option and data value or not. 
 
[Sequence] 

1) Select menu [Graph]-[Screen setting]. 
 

[Communication box] 

 
 
[Communication box description] 

a) View all: Display Bit, Trend, XY graph.  
b) View bit graph: Display bit graph. 
c) View trend graph: Display trend graph only. 
d) View XY graph: Display XY graph. 
e) View bit graph value: Display bit graph value. 
f) View trend graph value: Display trend graph value. 
g) View XY graph value: Display XY graph. 
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11.7.5  Graph Function 
 

(1) Show Cursor 
 
Display data value of mouse position on the graph. 
 
[Sequence] 

1) Proceed menu [Graph]->[Show cursor]. 
2) Select graph with mouse left button. According to mouse pointer, data is displayed. 

 
 

 
Notes  

 
Show cursor function revitalize only when monitor/trend monitor is ended.  
 

 
(2) Scroll synch 

Set that synchronize time axis of bit graph and trend graph or not. This is useful for monitoring bit graph data and trend graph at 
the same time.  

 
[Sequence] 

1) Proceed menu [Graph]->[Scroll synch]. 
2) Move horizontal bar. Bit graph and trend graph are scrolled by setting scroll synch or not. 
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(3) Magnification control of axis X 
 
Control magnification of axis X. 
 
[Sequence] 

1) Proceed menu [Graph]->[Expansion of axis X], [reduction of axis X], [as original axis X]. Time interval of axis X is 
expansed or reducted by selected item. 

 
 

(4) Magnification control of axis Y 
 
Control magnification axis Y. 
 
[Sequence] 

1) Proceed menu [Graph]->[Expansion of axis Y], [reduction of axis Y], [as original axis Y]. Time interval of axis Y is 
expansed or reducted by selected item. 

 

 
 

(5) Auto align of axis X 
 
Set auto align of axis X or not. Horizontal scroll bar is disappeard after auto aligns and whole data can show at once. 

 
[Sequence] 

1) Proceed menu [Graph]->[Auto align axis X]. 
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(6) Auto align axis Y 

 
Set auto align of axis Y or not. Axis Y auto align only apply to trend graph. 

 
[Sequence] 

1) Proceed [Graph]->[Auto align of Axis Y]. 
 

Notes  
 
Trend graph is displayed by min/max value which is set unless auto align of axis Y. 
 

 
(7) Save bitmap 

 
Save graph on the current screen as bitmap file. 

 
[Sequence] 

1) Proceed menu [Graph]->[Save bitmap]. 
2) Confirm button after saving file. 

 
(8) Save text 

 
Save graph data as text file. Samples are saved as the number of set maximum sustained samples. 
 
[Sequence] 

1) Proceed menu [Graph]->[Save text]. 
2) Confirm button after inputting save file name. 

 
Notes  

Use .CSV format of excel for saving text file. 

 
 

(9) Copy Clipboard 
 
Copy present graph to window clip board. 
 
[Sequence] 

1) Proceed menu [Graph]->[Copy clipboard]. 
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11.8  Data Trace  

(only applied to XPM, network type XPM, standard network type XPM) 
 
Set device for trace and trace codition on module. When it satisfies condition, collect data from module. Display data that it is read from 
module by graph on XG-PM. This function is similar with trend monitor (This manual 11.7), can collect accurate data, because can 
collect interval of max module scan. 
 
 
This is sequence for data trace. 
 

Sequence Contents 

 

Connect with module. 

Set whether to allow trace and set trigger, sample attribute, trace device. Refer to this 
manual 11.7.2 for detail. 

Record to module about trace setting item. Refer to 1) Write to trace setting of this 
manual 11.7.8 for detail. 

Start to trace. Start automatically by set trigger condition or select manual trace. Refer to 
11.7.2 for trace setting, refer to 11.7.8 for manual trace. 

Read trace data from module. Refer to 11.7.8 for 3) Read trace. 

Refer to 11.7.9 for detail. 

 
[Sequence] 
 

1) Proceed menu [Monitoring]->[Data trace]. 
 

Tip  

 
Trace result data saved at the module is removed when module power is off. (not saved at the module) 
So, when turning on the module, can’t read that result data. 
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[Data trace screen] 

 
 
[Data trace setting screen] 

a) Menu: Display data trace menu. 
b) Instrument collection: View bit graph : Display bit graph. 
c) Select trace setting module: Select trace setting data module. 
d) Bit graph index: Display bit device and graph color. 
e) Bit graph: Display bit device and data. 
f) Word graph index: Display word device and graph color. 
g) Word graph: Display word device data. 
h) State bar: Display state of data trace. 
i) Trend graph tab: Display bit device and word device trace data on a screen. 
j) XY graph tab: Axis X and Y set device and display circle data by 3D data. 
k) XYZ graph tab: Axis X,Y,Z set device and display circle data by 3D data. 
l) Progress bar: Display progress state, if read data from module. 
m) Trace state: Display trace state of module. 
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11.8.1  Connection 
 

[Sequence] 
1) Proceed menu [Online]->[Connect]. 

 
Notes  

 
When proceed XG-PM [Monitoring]->[Data trace], automatically proceed [Online]->[Connect].  
 

 

11.8.2  Trace setting 
 

Set trace condition and trace device. 
 

[Sequence] 
1) Data trace menu [Trace]->[Trace setting]. 

 
[Communication box] 

 
[Communication box description] 

a) Permit trace: Set trace permission or not. 
b) Trace start condition: Set trace starting condition. Can select bit condition and word condition. 
c) Trace start condition (bit): Decides whether setting bit trigger condition or not and set device for watching bit trigger 

condition. 
d) Trace start condition (word): Decides whether setting word trigger condition or not and set device for watching word 

trigger condition. 
e) Trace stop condition: Set trace stop condition. Can select bit condition or word condition. 
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f) Trace stop condition (bit): Decides whether bit trigger condition or not, set device for watching bit trigger condition. 
g) Trace stop condition (word): Decides whether setting word trigger condition or not and set device for watching word 

trigger condition. 
h) Sample setting: The number of data trace samples and set sampling periods. 
i) Sampling Frequency : Set data collection cycle. Can set maximum 131072 by multiple of scan periods. 
j) Total samples: Set the number of samples for collection. The number of total samples is decided by sample device. 
k) OK : Save changed item and close the communication box. If the module is onlined, current setting data 

automatically write to module. 
l) Cancel: Close communication.  

 
(1) Bit trigger setting (Trace starting condition and stop condition common) 

 
Use changing device value as trigger condition. 
 
[Sequence] 

1) Select bit condition check box. 
2) Select device for bit condition. (Axis setting and device setting) 
3) Set trigger condition. Can select rise or fall as trigger condition. (Rise: device value change to 1 from 0, Fall: Device 

value change to 0 from 1) 
  

(2) Word trigger setting (Trace starting condition and stop condition common) 
 
Use changing word device value as trigger condition. 

 
[Sequence] 

1) Select word condition check box. 
2) Select device for word condition. (Axis setting and device setting) 
3) Input constant that it is compared with word device. 
4) Select condition that it is compared with inputted constant.  

Available select function is as follows:. 
<(Small), <= (Small or equal), ==(equal), >=(Big or equal), >(Big) 
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(3) Bit device setting 

 
Select bit device for collecting data. Bit device display selected device. 

 
[Sequence] 

1) Select bit device setting tab on the data trace setting communication box. 
2) Select bit type device. If need to add line or delete line, select menu by right mouse button. 

 
[Communication box] 

                   
 

[Communication box description] 
a) The number of setting devices: Display the number of set devices. 
b) Setting data size: Display setting data size. If need to set devices more than one, it is displayed by 2 byte. 
c) Device catalogue: Display set device catalogue. 

 
 

Notes  
 
Device can be set max 8 with word device and bit type device.  
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(4) Word device setting 

 
Select word device for collecting data. Word graph display selected device. 

 
[Sequence] 

1) Select word device setting tab on the data trace setting communication box. 
2) Select word type device. Select menu by mouse right button, when need to add or delete line. 

 
 
 

[Communication box] 

           
 

[Communication box description] 
a) The number of setting devices: Display the number of set word devices. 
b) Setting data size: Display setting data size. Size is decides by set data type. 
c) Device catalogue: Display set word device catalogue. 
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11.8.3  XY Trace Setting 
 
XY trace setting after proceed data trace that it display 2D data on the XY coordinate by recorded word device, set X device, Y 
device. 

 
[Sequence] 

1) Revitalize XY graph tab. 
2) Revitalize menu by click right button, select [XY trace setting] menu. 

 
[Communication box] 

 
[Communication box description] 

a) Configured Number: Display the number of XY devices. Have to set axis X device and axis Y device for increasing a 
device. 

b) X axis device: Set device for recording on the axis X.  
c) Y axis device: Set device for recording on the axis Y. 
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11.8.4  XYZ Trace Setting 
 
Set axis X,Y,Z devices to display 3D data on the XYZ coordinates by recorded word device. 

 
[Sequence] 

1) Revitalize XYZ graph tab. 
2) Click right button to revitalize menu, select [XYZ trace setting] menu. 

 
[Communication box] 
 

 

[Communication box description] 
a) Axis X device: Set device to record on the axis X. 
b) Axis Y device: Set device to record on the axis Y. 
c) Axis Z device: Set device to record on the axis Z. 
d) OK: Save XY trace setting and end communicator. 
e) Cancel: End communication box. 

 
 

Notes  
 
XY trace setting and XYZ trace setting not save to module. 
 

 
 
 
 
 
 



 

 

 

 

 

 Chapter 11 Useful Function of XG-PM 

 

 

    

11-61 

 

11.8.5  Graph Setting 
 

Set graph of trend graph tab. 
 

[Sequence] 
1) Revitalize trend graph tab. 
2) Proceed menu [Graph]->[Graph setting]. 

 
[Communication box] 

 
 

[Communication box description] 
a) Show grid: Decides whether setting display grid on the screen or not. 
b) Bit graph legend position: Set position of bit graph index. 
c) Word graph legend position: Set position of trend graph index. 
d) Color setting: Set general color and device color of graph background. 
e) OK: Apply change and close communication box. 
f) Cancel: Close communication box. 

 
(1) Graph color setting method  

 
[Sequence] 

1) Select line for changing graph color. 
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2) Click color line. Communication box to be displayed, if click the color line. Select communication box and confirm. 

 

 
 

11.8.6  XY Graph Setting 
 

Set graph of XY graph tab. 
 

[Sequence] 
1) Revitalize XY graph tab. 
2) Proceed menu [Graph]->[Graph setting]. 

 
[Communication box] 
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[Communication box description] 

a) Show Grid: Decides whether setting display XY grid. 
b) Fix XY graph grid ratio: Set grid rate of XY graph. When it check, grid vertical and horizontal rates are same. When it 

uncheck, display rate with screen rate. 
c) XY graph legend position: Set position of X graph index.  
d) Color setting: Set device color and general color of graph backround. 
e) OK: Close communication box after setting. 
f) Cancel: Close communication box. 

 

11.8.7 XYZ Graph Setting 
 

Set XYZ graph tab. 
 

[Sequence] 
1) Revitalize XYZ graph tab. 
2) Proceed menu [graph]->[graph setting]. 

 
[Communication box] 

 
 
[Communication box description] 

a) Show grid: Decides whether setting XYZ grid or not. 
b) Fix XYZ graph grid ratio: Set grid rate on the XYZ graph. When it check, grid vertical and horizontal rates are same. 

When it uncheck, display rate with screen rate. 
c) Color setting: Set device color and general color of graph background. 
d) OK: Close communication box after changing. 
e) Cancel: Close communication box. 
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11.8.8  Trace 
 

Read traced data from module or read setting. 
 

(1) Write trace setting 
 
Apply trace setting to module. 
 
[Sequence] 

1) Proceed menu [trace]->[Writing trace setting]. 
 

(2) Read trace setting 
 
Read trace setting from module.  
 
[Sequence] 

1) Proceed menu [Trace]->[Read trace setting]. 
 

Notes  

When proceed data trace with XG-PM, first trace setting read is automatically start one time. 

 
(3) Reading Trace 

 
Read data of trace result from module. 
 
[Sequence] 

1) Proceed menu [Trace]->[Reading trace]. 
 

(4) Starting manual trace 
 
Begin to data trace by current set trace condition. 
 
[Sequence] 

1) Proceed menu [Trace]->[Starting manual trace]. If it is tracing now, menu to be inactivated. 
 

(5) Stopping manual trace 
 
Manual trace stop make stop trace and read data to present.  

 
[Sequence] 

1) Proceed menu [Trace]->[Stopping manual trace]. It is revitalized only operate previous trace menu. 
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11.8.9  Playing Trace 
 

It is displayed by trace data that it read from module with time. 
 

(1) Play setting 
 
[Sequence] 

1) Proceed menu [Playing trace]->[Play setting]. 
 

[Communication box] 

 
[Communication box description] 

a) Data Refresh: Set renew period of data sample. 
b) OK: Close communication box with applying change. 
c) Cancel: Close communication box. 

(2) Start  
 
Begin to play trace. Playing trace is revitalized only, when there are trace data. 
 
[Sequence] 

1) Proceed menu [trace playing]->[Play setting]. 
 

(3) Pause  
 
Pause trace. 
 
[Sequence] 

1) Proceed menu [Playing trace]->[Playing pause/continue]. 
 

(4) Continue 
 
Continue paused trace. 
 
[Sequence] 

1) Proceed menu [Playing trace]->[Playing pause/continue]. 
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(5) Stop 

 
End playing trace. 
 
[Sequence] 

1) Proceed menu [Renew playing trace]->[Stop playing]. 
 

11.8.10  Graph Function 
 

Refer to graph function (11.7.4) of this manual 11.7 trend monitor. 
 
 

11.8.11  File Function 
 

Save trace setting, read setting from file. 
 

(1) Open 
 
[Sequence] 

1) Proceed menu [File]->[Open]. 
2) Confirm after selecting the file on file communication box. 

 
(2) Saving  

 
[Sequence] 

1) Select menu [File]->[Save]. 
2) Input file name that it need to save on the file saving communication box and confirm. 

 
(3) Save as … 

 
[Sequence] 

1) Proceed menu [File]->[Save as …]. 
2) Input file name that it need to save as other name and confirm. 

 
(4) Save bitmap 

 
Save present graph as bitmap file. 
 
[Sequence] 

1) Proceed menu [file]->[out] ->[Save bitmap]. 
2) Input file name what you need to save and confirm. 
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(5) Save text 

 
Save graph data as text file. To be saved data as the number of datas on the current screen.  
 
[Sequence] 

1) Proceed menu [File]->[Out] ->[Save text]. 
2) Input file name what you need to save and confirm. 

 
(6) Copy clipboard 

 
Graph on the present screen, Copy to window clipboard. 
 
[Sequence] 

1) Proceed menu [File]->[Out] ->[Copy clipboard]. 
 
 

11.8.12  View Function 
 

Display or hide tool bar and status bar. 
 

(1) View tool bar 
 
[Sequence] 

1) Select/Cancellation menu [View]->[“Tool name”]. 
 

Notes  

“Tool name” include file tool/trace tool/graph tool/recycle tool. 

 
(2) View status bar 

 
[Sequence] 

1) Select/Cancellation menu [View]->[Status bar]. 
 

(3) View data 
 
Display Trace data by value. View data item is revitalized with trace data only. 
 
[Sequence] 

1) Proceed menu [view]->[View data]. 
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[Communication box] 

 
[Communication box description] 

a) Sampling Frequency: Display scan period by trace setting. 
The number of total samples: Display the number of collected total samples. 

b) View settings: Display trace setting communication box. 
c) Data: Display data trace result value in order of sample. Sample data display the number of collected samples on the 

basis of a trace time-point. 
d) Min/Max data, average value. 
e) Close: Close communication box. 
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11.9  Electronic CAM  

(only applied to XPM, network type XPM, standard network type XPM) 
 
XG-PM provides function that it creates electronic CAM profile and operate electronic CAM. User proceed “editing cam data and 
confirm  Download to module  Cam operation command” for CAM operation. 
 
This is a sequence of operating electronic CAM. 
 

Sequence Contents 
 

Select one of 8 CAM block for setting. 

Set CAM control mode. When make increasing profile to one direction or repeat one 
section, set repeat mode.  

Set main/sub parameter. Refer to 8.4 electronic CAM setting for details. 

Set CAM data of selected block. Refer to 8.4 electronic CAM setting for details. 

Create CAM profile by set blockdata. 

Confirm created profile by graph and data. If user wants to modify profile, reset CAM 
block data. 
Fine modification of CAM profile is available through editing the sub axis position. 

Download profile to module.  

Operate CAM profile that it is saved on module by command. 

 
 

11.9.1  Creating electronic CAM profile  
Refer to 8.4 electronic CAM setting for CAM data setting and CAM profile creation proceeding. 

Select CAM block

Setting CAM control mode

Setting Main axis/Sub axis 
parameter

Setting CAM block data
(Considering characteristic 

curve)

Creating profile

Download CAM block data

Operating CAM by command

Confirm graph and data
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11.9.2  Proceeding electronic CAM  
 

Operate electric CAM of XG-PM after downloading CAM profile to module XG-PM. 
 

[Sequence] 
1) Select axis command. (Select from command tool) 
2) Set main axis from item of expansion command window CAM operation.  
3) Select CAM block. 
4) Click confirm button. 

 
[Setting screen] 
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11.10  Network Servo Auto Connect (only applied to standard network type XPM) 
 

XG-PM provides ‘Network Servo Auto Connect’ function for you to connect the servo drive easily. This function is to connect the 
servo drive automatically using the driver information saved at the module while online status, not setting network parameter.   
You can connect the servo drive easily without network parameter setup by using ‘Network Servo Auto Connect’ function. 

 
[Sequence] 

1) Select menu [Online]  [Network Servo Auto Connect] 
2) Servo drive is connected, setting up network parameter automatically. 

 
Note  
 
Since this function uses the driver information saved at the module to set up network parameter, auto-connection function is not 
available for all servo drives. Servo drives supporting auto-connection are as follows.  

 
Maker Driver name 

LS Mecapion APD-L7E 
APD-VE 

Sanyodenki Co.Ltd. R ADVANCED MODEL with EtherCAT Coe 
Interface 

Beckhoff Automation GmbH AX2000-B110 EtherCAT Drive (CoE) 

Danaher Motion GmbH AKD EtherCAT Drive (CoE) 
S300/S400/S600/S700 EtherCAT Drive (CoE) 

Yaskawa Electric Corporation 

SGDV-E1 EtherCAT(CoE) SERVOPACK REV3 
SGDV-E1 EtherCAT(CoE) SERVOPACK REV2 
SGDV-E1 EtherCAT(CoE) SERVOPACK REV1 
SGDV-E5 EtherCAT(CoE) SERVOPACK REV3 
SGDV-E5 EtherCAT(CoE) SERVOPACK REV2 
SGDV-E5 EtherCAT(CoE) SERVOPACK REV1 

Schneider Electric Motion 

ICLA ILA2 PLCOpen 
ICLA ILA2 DS402 
ICLA ILS2 PLCOpen 
ICLA ILS2 DS402 
ICLA ILE2 PLCOpen 
ICLA ILE2 DS402 

 
When connecting servo drive which doesn’t support ‘Network Servo Auto Connect’, you have to set up network parameter by 
yourself. For how to set up, refer to chapter 8.5 network parameter setting. 
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Appendix 1 What is the difference between APM software package and  
XG-PM. 

 
Appendix1.1 Difference  
 

         PADT 
 Item APM Software package XG-PM 

Supported module 
1) XGF-PO1A /PO2A/PO3A (3 types)  
2) XGF-PD1A/PD2A/PD3A (3 types) 

1) XGF-PO1A/PO2A/PO3A (3 types)  
2) XGF-PD1A/PD2A/PD3A (3 types) 
3) XGF-PO1H/PO2H/PO3H/ PO4H (4 types)  
4) XGF-PD1H/PD2H/PD3H/PD4H (4 types) 
5) XGF-PN8A (1 type)/XGF-PN8B(2 types) 

Programming structure 

1) Single module programming method 
2) Cannot comparison operation data/parameter 

screen at once. 
3) No support copy/attach parameter/operation 

data on the project tree. 

1) Multi module programming method 
2) Support comparing Operation data/Parameter screen at 

once 
3) Function of copying/attaching parameter/profile data. 

Editorial function 
No support data copy. attach without same item. 
No support /Undo/Redo. 

Support function for data copy/ attach/ Undo/ Redo with 
difference item. 

Parameter detail 
setting 

No support 
Provide parameter detailed setting function with help  
(Description + Graphic) 

Online module setting One module online function 

1) Online synch function 
(It is possible that it synchronize module information on 
system and project structure on the program.) 

2) Multi module online function 
Read data/ Write/ 
Comparison with 

module 
No support 

Support comparison function of read/write/module project. 
(Multi module) 

Communication sharing 
It is impossible that it share communication port 
with other software. 

It is possible that it share communication port with XG5000 
software. 

Module O/S download No support Support download function of multi module O/S. 

File Import/Export No support 
Can save and load as operation data/operation parameter 
file. 

Monitoring Not provides graphic monitor function. 
Graphic monitoring 
(System monitor, Display module OS information.) 

Trace Provides data Tracking function. Data trace, X/Y trace, XYZ trace function. 
Simulation Profile/ Circular interpolation simulation Operation simulation 

Print Provide a module printing function. Provide project printing function. (Print multi module) 
Servo tuning  No support Support (network type XPM) 

CAM setting function No support 
CAM profile setting (22 types), Data analysis/ Display 
editorial CAM graph. 

Help Descript basic operation. Menu tool tip each function and promote help. 
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Appendix1.2 Menu List 
     
1.2.1. Menu list 

(1) File 

APM software package XG-PM Remark 

New File Project >> New Project Available to change File -> Project 

Open  Project >> Open Project Available to change File -> Project 

Save  Project >> Save Project Available to change File -> Project 

Save as Project >> Save as Project Available to change File -> Project 

Print Project >> Print Supports Project Print 

Print Setup Print Setup - 

Recent File Recent File - 

Environement Setting Environment Setting 
“Change step number” is available by 
“Change Module Registration 
Information” 

Exit Exit - 

 
(2) Edit 

APM software package XG-PM Remark 

Copy Copy Same as XG5000  

Paste Paste Same as XG5000 

Undo  Undo Same as XG5000 

Redo Redo Same as XG5000 

Initial value seutup Initial value setup - 

 
(3) Data 

APM software package XG-PM Remark 

Operation parameter - Unnecessary part is removed 

X-axis operation data - Unnecessary part is removed 

Y-axis operation data - Unnecessary part is removed 

Z-axis operation data - Unnecessary part is removed 
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(4) Communication 

APM software package XG-PM Remark 

Comm. Enviroment setting Online >> Connection Setting Same as XG5000 

Connect Online >> Connect Same as XG5000 

Disconnect Online >> Disconnect Same as XG5000 

Read/Write Data 
Online >> Write 
Online >> Read 

Same as XG5000 

 
(5) Tool 

APM software package XG-PM Remark 

Online model setup Online >> Online model setup Multiple module setup is available 

Offline model setup View >> Registeration information Module information setup is available 

Operation status monitoring Monitoring>> Start/End monitoring Same as XG5000 

Profile Tracking Monitoring >> Trend monitoring Same as XG5000 

Profile Simulation 
Tool >> Profile/Circular interpolation 
simulation 

- 

Circular Interpolation simulation 
Tool >> Profile/Circular interpolation 
simulation 

- 

 
 

(6) View 

APM software package XG-PM Remark 

Main tool Basic tool - 

Command tool Command tool - 

Tracking tool Trend tool Same as XG5000 

Simulation tool Simulation tool - 

Status bar - Same as XG5000 

Worke space Project window Same as XG5000 

External I/O signal and status screen I/O window Simplify terminology 

Error History information Error Status / Error History Separate item 

 
(7) Help 

APM software package XG-PM Remark 

APM software package information About XG-PM  - 

About Help XG-PM Help - 
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1.2.2. Toolbar list 
 

1. Entire toolbar 

 
2. Basic toolbar 

 
 

Command 
icon Commend Description Remark 

 New Project  Creates new project Common

 Open Project Opens previous project Common

 Save Project Saves project Common

 Properties 
Activates detailed information dialog box on the selected item at the 
project window (Ex) Project and module information 

Common

 Cut Initilizes data of the selected shell area and copy data to clipboard Common

 Copy  Copies data to clipboard Common

 Paste  Copies data from cllipboard to the selected shell area Common

 Initial value setup Initilizes data of the selected shell area Common

 Undo 
Cancels the editing at the selected item window and return to the 
previous status 

Common

 Redo Restores the canceled operation Common

 
Detailed parameter 

setup 
 Shows detailed paramter window at the operation paramter Common

 Print  Prints contents of the activated window  Common

 XG-PM Information  Shows XG-PM’s information Common

 Connect/Disconnect  Connect to/disconnect from PLC Common

 Connection setting  Sets up connection method Common
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3. Command toolbar 

 
 

Command 
icon Commend Description Remark 

 Axis stop  Selected axis dec. stop command Common

 EMG stop Internal EMG stop command during operation Common

 Home return Home return command according to Home return method Common

 Floating origin setting Software origin setting command Common

 
Speed/Position 

switching 
Switches speed control to position control during operation  Common

 
Position/speed 

switching 
 Switches position control to speed control during operation Common

 Skip operation  Stops current step and run next step Common

 Continuous operation 
 Changes operation pattern of the current step to continuous operation 
 and runs next step without stop 

Common

 
Return to position 

before manual 
operation 

 When positioning complete position is changed by manual operation 
 such as JOG operation and Inching operation after positioning 
 complete, moves to the position before manual operation 

Common

 Cancel M code  Cancels M code when M code arise  Common

 Enable ZONE output  Enables ZONE output APM 

 Disable ZONE output  Disables ZONE output APM 

 Enable MPG  Enables MPG function APM 

 Disable MPG  Disables MPG function APM 

 Error history reset  Clears entire error history Common

 Error reset  Clears current error  Common

 
 
 
 
 
 
 
 



 

 

 

 

 

 Appendix1 What is the difference between APM software package and XGPM 

 

 APP1-6 

 
 

4. Online toolbar 

 
 

Command 
icon Command Description Remark 

 Online model setup 
Checks the module under online status and add to the project.  
When selecting the module, it reads data from that module 

Common

 Write Writes the data to module Common

 Read Reads the data from module Common

 Compare with module 
 Compares the data in the module and in the project and shows the result 
 at “Compare with module” tap 

Common

 Module information Shows the module information under online status at the screen Common

 Start/End monitoring Starts/Ends monitoring Common

 Trend monitor Executes trend monitoring Common

 Data trace Specifies the device and monitors the data change of that device  
XPM, 

Network 
type XPM

 
5. Trend toolbar 

 
 

Command 
icon Command Description Remark 

 Start trend monitoring   Starts (restarts) trend monitoring  Common

 Stop Trend monitoring  Stops (pauses) trend monitoring Common
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6. View toolbar 

 
 

Command 
icon Command Description Remark 

 Project window  Shows or hides project window Common

 Command window Shows or hides command window Common

 I/O window Shows or hides I/O window Common

 Message window Shows or hides message window Common

 Detail view Executes paramter detail view Common

 Simple view Executes paramter simple view Common

 Error status Activates error status tap at the message window Common

 Error history Activates error history tap at the message window Common

 
7. Window toolbar 

 
 

Command 
icon Command Description Remark 

 Cascade  Arrays windows in XG-PM in cascade Common

 Tile Arrays windows in XG-PM horizontally  Common

 Tile Arrays windows in XG-PM vertically Common

 Close all  Close all windows in XG-PM Common
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8. Servo toolbar 

 
 

Command 
icon Command Description Remark 

 Connect to all servo  Connects all servo drives connected to the module 
Network 

type XPM

 Disconnect to all servo  Disconnects all servo drives connected to the module 
Network 

type XPM

 Servo on Turn on the selected axis servo 
Network 

type XPM

 Servo off Turn off the selected axis servo 
Network 

type XPM

 All servo station setting Sets up station number of all servo 
Network 

type XPM

 Servo tuning  Tunes servo drive  
Network 

type XPM
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Warranty 
 
 
1. Warranty Period 

 The product you purchased will be guaranteed for 18 months from the date of manufacturing.  
 
2. Scope of Warranty 
   Any trouble or defect occurring for the above-mentioned period will be partially replaced or repaired. However, please note the following 

cases will be excluded from the scope of warranty.  
  

(1) Any trouble attributable to unreasonable condition, environment or handling otherwise specified in the manual,  
(2) Any trouble attributable to others’ products, 
(3) If the product is modified or repaired in any other place not designated by the company,  
(4) Due to unintended purposes 
(5) Owing to the reasons unexpected at the level of the contemporary science and technology when delivered.  
(6) Not attributable to the company; for instance, natural disasters or fire 
 

 
3.  Since the above warranty is limited to PLC unit only, make sure to use the product considering the safety for system configuration or 

applications.  
 
 
 

 

Environmental Policy 
 
 
     LSIS Co., Ltd supports and observes the environmental policy as below.  
 
 
 
  

 
LSIS considers the environmental preservation 
as the preferential management subject and 
every staff of LS Industrial Systems use the 
reasonable endeavors for the pleasurably 
environmental preservation of the earth.   

 
 
     

LSIS PLC unit is designed to protect the 
environment. For the disposal, separate 
aluminum, iron and synthetic resin (cover) from 
the product as they are reusable.   

Environmental Management About Disposal 
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